Counter-Strike2 CS2 Stuttering on nVidiaRTX with Plasma Wayland

I know that there was some problems still in this field, but was wondering maybe someone got it working somehow?

X11 Flatpak Steam works with CS2.

RTX 3050, on laptop, under Plasma Wayland, playing CS2 without an issues. Perhaps try the native version of Steam, not the Flatpak version.

Here are my launch options: __NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only __GLX_VENDOR_LIBRARY_NAME=nvidia %command%

1 Like

Launch options for Steam or CS2 itself?

Those are for the game.

1 Like

It didn’t work. Now I’m using Wayland Arch Plasma Steam.

I have AMD5950X RTX3090 and nvidia-dkms installed through endeavouros nvidia-inst.

FPS in game is around 165FPS on 4K@120Hz Hdmi2.1; but I see frame latency often exceeding 42ms.

Also I see CS2 through nvidia-smi command:

| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|=========================================================================================|
...
...
...
|    0   N/A  N/A   1045869    C+G   ...fensive/game/bin/linuxsteamrt64/cs2       6358MiB

Current CS2 launch options:

__NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only __GLX_VENDOR_LIBRARY_NAME=nvidia %command% -threads 16

Currently testing this:
https://www.reddit.com/r/cs2/comments/1ap69xr/counterstrike_2_how_to_native_wayland_support/

In file: /home/v1n1/.local/share/Steam/steamapps/common/Counter-Strike Global Offensive/game/cs.sh

Comment/delete line:
# export SDL_VIDEO_DRIVER=x11

Helps to clear large stutter. Now it feels like playable, but like in low fps (but FPS is high).

In Plasma desktop settings set refresh rate to match my monitor to 120Hz, AdaptiveSync Always, Enable HDR, Allow tearing.

Now gameplay looks cinematic smooth.


Also apply my previous comment needed.


CS2 launch options:

%command% -threads 32

Threads depending on my CPU threads.


Also:

__NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only __GLX_VENDOR_LIBRARY_NAME=nvidia 

not needed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.