Corrupted kernel after PC crash during update

Hello everyone, I’m very worried about my EOS install and I was hoping you guys could help me.

I was updating my system and my PC crashed during the update, because the specific model of my GPU does that sometimes. When I rebooted the PC, this message appeared:

I think the kernel has been corrupted. I have no idea if this can be solved but I want to avoid installing EOS again at all costs. Any help would be appreciated!

Boot off the iso, arch-chroot into you system as described in the wiki and reinstall the kernel package and update the system.

No o reinstall should be needed.

5 Likes

I’m in the ISO but I cannot arch-chroot into my system, for some reason. I will try this again tomorrow. Thank you.

This worked. Thank you so much.

I simply plugged the USB with the ISO file and updated the kernel with “pacman -S linux” (with root access). This should’ve taken five minutes, not hours; I had some problems with arch-chroot and did some unnecessary steps. Thank you again !

1 Like

One hour later:

I’m guessing it was between 23:00 and midnight when the first of these was posted, so tomorrow was less than an hour away :rofl:

I’m glad your issue is resolved!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.