Corrupted hwinfo, can't update

Hi everyone,

I just got back from nit using this computer for two weeks and just got this error message while trying to update:

Preformatted texterror: hwinfo: signature from “Alexander F. Rødseth xyproto@archlinux.org” is marginal trust
:: File /var/cache/pacman/pkg/hwinfo-22.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).Preformatted text

It won’t let me delete it nor can I update. I’m not sure what to do next.

Thanks for any suggestions

sudo pacman -Sy archlinux-keyring
sudo pacman -Syu
2 Likes

Bingo. So that I don’t die stupid, or halfway, ```
-Sy archlinux-keyring


I just got this error message. I'm going to uninstall qemu.

error: failed to commit transaction (conflicting files)
seabios: /usr/share/qemu/bios-microvm.bin exists in filesystem (owned by qemu-git)
seabios: /usr/share/qemu/vgabios-ati.bin exists in filesystem (owned by qemu-git)
Errors occurred, no packages were upgraded.

type or paste code here

Try replacing qemu-git with qemu

yay -Syu qemu

So far so good. A reboot and I’m back. Thanks friend!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.