Continuously crashing

Im having an issue with EndeavourOS and BSPWM.

Everything installs perfectly and appears to be fine. Soon as it restarts from any point of typing my password in to just doing anything within the os my laptop will just freeze to the point i have to manually force a restart.

Ive tried all different types of patterns to try replicate this but it can be anything, i can see resource wise its using absolutely nothing.

Its not a particularly fast laptop, i bought it to play with linux but ive tried all different things (plasma etc) on the laptop and they all run fine.

Spec:
CODA 12
Intel Celeron N3450
4gb ram

Anyone else had this or could shed any light, it would be appeciated, really want to try out BSPWM!

Random freezes tend to be hardware-related. However, if other DEs work then that becomes less likely.

I’d suggest using

if they work, then you can install bspwm separately and see if it’s a bug in the WM or something you have set up/configured since installation.

Edit:

Looks like you’ve opened a bug report on the upstream issue tracker,

so I assume you’ve also looked through other issues too (like https://github.com/baskerville/bspwm/issues/1398). The developer has requested additional information so I’ll not duplicate effort here.

Hi thanks for replying, so ive currently swapped to manjaro and put on bspwm and its been working fine for the last hour or so.

Manjaro will have a different set of package versions, so when it eventually reaches the same state as Arch it will be interesting to see if you hit the same issue again.

Then, of course, you’ll be able to ask the same question again on the Manjaro forum!

4 Likes

Course im just problem solving lol, i appreciate the sarcasm :slight_smile:

1 Like

Are you using bspwm or the bspwm-manjaro package?

bspwm-manjaro, its ok, im just trying to learn some of the basics, its fairly new to me exploring linux. I will swap back to endeavour and get it running dw :slight_smile:

1 Like

OK, that’s interesting because it’s an older package version (plus might have other patches etc.):

image

Could well mean there’s a bug in bspwm 0.9.10…

If/when you’re back on Arch/EnOS it might be interesting to try that matching version 0.9.7 from https://archive.archlinux.org/packages/b/bspwm/ and see if the issue persists.

1 Like

Thats a good shout actually, i bought a laptop to purely explore linux so im formatting regularly till i find what i like and i know i like EnOS especially. Ill give it a whirl tomorrow trying both bspwm and bspwm-manjaro.

Thanks for your help, it is appreciated, i am on the enOS bandwagon dw :slight_smile:

1 Like