Constant MCE related reboots

Hello, I’ve been getting random reboots during time at desktop. Never seen it happen when gaming. The screen also turns green right before it reboots.
I read that its an issue with Ryzen 5000 series processors. I’ve tried everything that I’ve looked up. Tried all the fixes on the arch wiki. Tried everything on the Gentoo wiki. And I also tried everything on the AMD forums (increased DRAM voltage by 0.05). The fixes help and its been happening less and less but its still happening. I don’t think its a hardware issue because I dual boot and I don’t see anything wrong on Windows. I also did two passes of memtest86+.

Here is my journalctl log:

Additional logs:

read this and post some logs from inxi -Fxxc0z | eos-sendlog from journalctl -k -b -0 | eos-sendlog

Partition info below

Posted them

Here is a potential fix I found. I’m currently using the script from There is also a service that uses this script if you prefer that option as well I also found that adding amdgpu.dpm = 0 in grub could also help. Testing both of these fixes and will update this post if I run into an error.

Have you also tried the following kernel parameter?



There is also another UEFI Bios update with a new AMD AGESA. I would suggest you update to the latest as the AMD AGESA is extremely important for the Ryzen processors.

I have that boot parameter already. amdgpu.dpm = 0 didnt let me boot.
These are my boot parameters:
GRUB_CMDLINE_LINUX_DEFAULT=“nowatchdog nvme_load=YES loglevel=3 processor.max_cstate=5 idle=nomwait rcu_nocbs=0-11 amdgpu.ppfeaturemask=0xffffbffd”
My system crashed while on desktop on discord recently. I did the bios update to support my b450m to support the 5000 series but not the most recent update. I will try that and see how that affects things.

1 Like

Ya try the new UEFI Bios update because the AMD AGESA is all the power related settings for the processor.

Updated Bios and redid my settings. Will post here if I get issues.

1 Like

Are you starting from an updated Bios set at defaults and starting from a base of no changes other than the default installed settings as per the install?

Sorry for the lack of update.
No, I used the same BIOS settings that I had previously.

  • Typical Current Idle
  • DRAM voltage increased by 0.05V (1.200 to 1.250V)
  • Positive offset of 6 in the CPU Curve Setting (dont remember the exact setting name)
    Basically I applied all the fixes I could find.

I’m thinking it might be a PSU issue. I have a 5700x and 7800xt and calculating my system on PCPartPicker its close to 500W and my current PSU is 550W I’m p sure. (I’m not at PC right now to check, my campus was closed down due to water issues and everyone had to leave). It’s a sea sonic bronze 550w I’m p sure. I go back on Saturday so I can check and confirm there.

Strange thing is that I have no issue within Windows.

Should I replace my PSU with a higher wattage + tier?

Edit: I think it’s a Seasonic s12iii. I found out that apparently it’s quite bad. I might replace it regardless.
Edit 2: Just ordered a 750W G7 EVGA Supernova. Will install it and get back to you.

You need a minimum of 700 Watt I would go 750 or 850 Watt! I think the EVGA will be good.


I personally don’t make many Bios setting changes related to under volting or over clocking etc. I’m also not a gamer. I just think it’s wise to start from the default Bios settings and then make changes one at a time if you are doing that in order to know that the problem is not being cause by settings that don’t work. I do feel your power supply was under spec required for this card.


1 Like

Installed my new power supply. I didn’t have much time because I was busy this week. If I encounter any mce related errors I will update this post. If not, consider it solved.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.