Connection problems on my Debian server

Ok, I have a odd situation I have been fighting with for a few weeks. I would post this to a debian forum, but this community doesn’t suck like the others. I know I can get help on here.

Anyway, I have a desktop running Debian Bookworm that was updated from Bullseye. It is running my Nextcloud server, Plex and a UniFi server on the main system, then on a VM I am running HomeAssistant OS. The server has an IP of *.120 and the VM has an IP of *.118 . Both machines also have a node in Tailscale.

I did the upgrade from Bullseye to Bookworm a while ago without problems. I didn’t have any problems until recently when I upgraded my machine. After I noticed my internet would start acting buggy and I noticed my UniFi devices (one USG router and 2 AP’s) would randomly try to re-adopt. I also noticed that if I tried to ping my server ( main OS, *.120) from any other machine I would get no response, but would get a response to the VM. However, when I tried to ping other machines from the server I would get a response from all other devices. I could also get a response from the server from any other machine If I used the Tailscale address. Only the local LAN address *.120 would not be able to ping.

If I restart the server everything comes up fine. The UniFi devices connect properly and I can ping and ssh into the machine from the LAN address just fine, but after a while this problem appears and partitally takes out the server. Any ideas?

FWIW. the Debian Forums do not suck AND they probably have more people who use Debian as a server.

1 Like

OK, I just registered and posted.