Connecting MX master 3 via bluetooth

A newbie here. I’m very happy with my EOS so far, but I’m having problems connecting my mouse (MX master 3S). I want to connect it via Bluetooth. First I tried via the GUI (KDE is my current desktop) but the mouse never appeared. Other devices appeared and were successfully paired. After that failed, I tried directly with bluetoothctl and the mouse did not appear.
I then installed bluez-utils-compat (which uninstalled bluez-utils). I then tried hcitool lescan to find the mouse, which also failed. I tried all these steps with the latest kernel and the lts kernel.

I can rule out that it is the mouse as I can connect it under Windows (on the same laptop (dual boot)) and it works with my Mac.

It would be nice if someone could help me with what else I can try or where I have gone wrong.

Thanks very much,

I would put bluez-utils back on and follow this guide
I see this has a physical switch you probably will have to play around with the switch. I had similar issues and changing the state of the switch a few times got me to show up and then pair

I basically followed the tutorial you posted as they enable Bluetooth and than either use a gui or bluetoothctl to connect to the device. As you suggested I installed bluez-utils again. Also tried other GUIs (blueman) but I still have no success.

use the Arch wiki

I did this as well. In that article it states that I should visit Bluetooth#Device does not show up in scan it links to the Bluetooth article in the arch wiki. There it says that I should try hcitool lescan. As I outlined in my initial post, I tried this without success.

I managed to get the mouse to work. I cannot say exactly what made the difference. Here is what I did:

I plugged in another USB dongle because I knew it worked with manjaro and the mouse. I also rebooted the laptop (Though I’m sure I did this in the meantime). After the reboot I searched for devices using the standard Bluetooth Application in KDE using the dongel as the interface. I was able to find and connect to the mouse. After that I removed the dongel and searched again using the built-in interface. Suddenly the mouse was there. I have no idea what made the difference but I can use it now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.