Connecting Ethernet Cable Hard-Blocks WIFI

The hardware switch isn’t pressed, it can’t be used to “enable” WIFI. Unplugging the ethernet cable re-enables WIFI automatically.

1: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes

Running rfkill unblock 1 disables “Soft block” only.

Do you have NetworkManager installed?

warning: networkmanager-1.20.0-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) networkmanager-1.20.0-1

Total Download Size:    2.77 MiB
Total Installed Size:  15.05 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] n

Here’s what’s happening backstage.

[   11.663377] e1000e: enp0s31f6 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[   11.663464] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s31f6: link becomes ready
[   11.693418] iwlwifi 0000:04:00.0: RF_KILL bit toggled to disable radio.
[   11.693423] iwlwifi 0000:04:00.0: reporting RF_KILL (radio disabled)
[  667.345670] e1000e: enp0s31f6 NIC Link is Down
[  667.544119] iwlwifi 0000:04:00.0: RF_KILL bit toggled to enable radio.
[  667.544124] iwlwifi 0000:04:00.0: reporting RF_KILL (radio enabled)
[  697.308589] e1000e: enp0s31f6 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[  697.310355] iwlwifi 0000:04:00.0: RF_KILL bit toggled to disable radio.
[  697.310363] iwlwifi 0000:04:00.0: reporting RF_KILL (radio disabled)

Plug Ethernet > Unplug Ethernet > Plug Ethernet.

Intel iwlwifi is always a pain. Are you sure it doesn’t have this new Intel iwd package that just came out installed. It’s causing some issues and i think it automatically installs because if you have intel wifi?
It’s inet wireless daemon! (iwd) …just asking? It’s meant to replace wpa supplicant.
It is installed i just checked.

Yep, present.

Any way to confirm it’s responsible for this nasty bug?

No it was just thought that was worth mentioning as it’s just fairly new and it has already caused some other problem here. You could try uninstalling it and see. I’m not sure it’s actually being used as it’s also on my system and i have broadcom wireless anyway. Don’t want to tell you to do something if it’s going to mess up your wirelss as iwlwifi is a pain. Wifi period is difficult if it doesn’t work out of the box.

WIFI works, but only if no ethernet cable is connected. Once a cable is connected, WIFI becomes “disabled by hardware switch”.

At first I thought it was a script left behind in /etc/NetworkManager/dispatcher.d/ (Described here), not the case sadly.

Do you have some funky set up or is this just ethernet and wireless?

No funk here, WIFI and ethernet only.

Worked fine in other arch distro. I will build EOS and Manjaro live .iso’s and compare. Could be a bug affecting specific hardware.

I think it has to to with a conflict with NetworkManager and some of the other networking components. Have you tried disabling NetworkManager then starting it and then enabling it?

netctl stop-all
systemctl enable NetworkManager
systemctl start NetworkManager

Still not working with Ethernet?

Nuked the install and started fresh with lts kernel.