Connecting DS4 controller makes game really slow

Weird problem. Whenever I run Ghost Recon Wildlands and try to use my DS4 controller, or even run the game the DS4 connected, the game just turns really laggy. Almost like the FPS drops from 60 to 15. If I boot the game without the controller connected, it runs just fine. As soon as I connect, the lag starts. If I disconnect the controller while the game is running and try to resume gaming, the lag persists.

I tried with GW2 and had no problems with lag while the controller was connected. So it must be an issue with Wildlands only, right?

I know practically nothing about that game, but the problem sounds like a bad (or missing?) driver for the DS4 controller, or something similar.
Do you have any driver, like ds4drv or ds4drv-git from AUR?

And a good start to debug issues is to watch journal live output:
journalctl -f
From a terminal while the issue happen…
You can also do write the logs to a file if you start this before launching the game:
journalctl -f > log.txt
So you can get read it after terminating the game.

Installed ds4drv, no change. I did run the game’s benchmark tool and noticed that fps was only 12-15 and GPU utilization was 0%.

Apparently this is an issue with many games using an XBox bluetooth controller. And since DS4 is recognised as and XBox controller in wine…

I’ll try to figure out how to make it show up as DS4 in wine. Apparently that will fix the issue.

Did you try ds4drv-git already? It might be a more up-to-date package (but don’t know for sure).
A bit of a long shot maybe…

Tried the git version. This one shows the DS4 button graphics in game, but they are mapped wrong and when I load the game it looks like one of the analog stics are stuck and the camera is just panning my character.

May i ask what you are playing these games on? What platform and is it on bluetooth or usb? Also what video card are you running?

Wine/Lutris. Using the non-steam version. I’ve tried running the game with plain Wine, but the performance is horrible and a lot of artifacts. I’m sure the issue is with how some games act with bluetooth controllers. I get a good 60+ fps after reboot with no controller connected. As soon as I turn on the controller, the game starts stuttering. My GPU is the GTX 1070.

Are you able to use it with usb or is it only wireless?

Works fine with USB. Issue is only with BT.

@His_Turdness Sorry i can’t be of much help. I’m not much of a gamer. The only thing that I can say is that sometimes some of these things are not fixable by just changing a setting or using different software. I don’t know what all your hardware is and there are a lot of different bluetooth specifications. I don’t know what version your hardware is or your controller. Sometimes firmware updates fix some of these issues sometimes not. Sometimes it’s software fixes on the game or the platform or wine or possibly linux. Hopefully a solution comes along and you find it. I guess in the mean time you may have to resort to using usb. Don’t give up looking though… the solution sometimes comes out of nowhere.

The solution is apparently going around the emulated XBox drivers. I tried it and looked like it worked too (didn’t benchmark it though), but I got the input issues, so I gave up on it.

Doesn’t effect all games, so it’s not that bad. Just a big annoyance that I can’t play Wildlands on my new TV in my living room. Not wirelessly anyway.