Conky on top of apps when switching workspaces

Okay i’m new to arch and linux in general but after some research i dont know if its a bug that can be resolve on my end.
So when i switch workspace the conky “widgets” go on top of all the apps
Here’s my conkyrc (conf created by the creator of the Mirack theme that i’m using) :

conky.config = {

--  Created : 2022/Jul/10
--  This theme is for conky version 1.10.8 or newer
--  ( A part of Scorpio Conky themes pack )
--  author  : Closebox73
--  license : Distributed under the terms of GPLv3
--  notes   : Created on 1366x768 Monitor


-- Size and Position settings --
  alignment = 'bottom_left',
  gap_x = 20,
  gap_y = 0,
  maximum_width = 500,
  minimum_height = 400,
  minimum_width = 500,
-- Text settings --
  use_xft = true,
  override_utf8_locale = true,
  font = 'Roboto:light:size=9',
-- Color Settings --
  default_color = 'white',
  default_outline_color = 'white',
  default_shade_color = 'white',
  color1 = '#ff5b5d',
  color2 = '#0081FF',
-- Window Settings --
  background = false,
  border_width = 1,
  draw_borders = false,
  draw_graph_borders = false,
  draw_outline = false,
  draw_shades = false,
  own_window = true,
  own_window_colour = '000000',
  own_window_class = 'Conky',
  own_window_argb_visual = true,
  own_window_type = 'desktop',
  own_window_transparent = true,
  own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
  stippled_borders = 0,
-- Others --
  cpu_avg_samples = 2,
  net_avg_samples = 2,
  double_buffer = true,
  out_to_console = false,
  out_to_stderr = false,
  extra_newline = false,
  update_interval = 1,
  uppercase = false,
  use_spacer = 'none',
  show_graph_scale = false,
  show_graph_range = false,
  lua_load = '~/.config/conky/Mirach/scripts/rings-v1.2.1.lua',
  lua_draw_hook_pre = 'ring_stats',

conky.text = [[
${execi 300 ~/.config/.conky/Mirach/scripts/}\
${offset 10}${color1}${font League spartan:bold:size=53}${time %^A}${font}
${offset 0}${voffset -25}${color white}${font League spartan:bold:size=50}${time %d}${offset -10}${color1}${font Great Vibes:light:size=29}${execi 300 ~/.config/conky/Mirach/scripts/number}${font}
${offset 0}${voffset 25}${color}${font Dosis:bold:size=13}- - - - - - - - - -   ${time %H:%M %^p}${font Dosis:size=1}
${offset 0}${voffset 25}${color}${font Dosis:size=10}Today's weather at ${execi 100 cat ~/.cache/weather.json | jq -r '.name'} : ${execi 100 cat ~/.cache/weather.json | jq -r '.weather[0].main'}, ${execi 100 cat ~/.cache/weather.json | jq '.main.temp' | awk '{print int($1+0.5)}'} °C
${offset 0}${voffset 0}${color}${font Dosis:size=10}Wind speed at your location : ${execi 100 (cat ~/.cache/weather.json | jq '.wind.speed')}m/s
${offset 0}${voffset 0}${color}${font Dosis:size=10}And Humidity : ${execi 100 (cat ~/.cache/weather.json | jq '.main.humidity')}%
${offset 0}${voffset 25}${color}${font Material:size=11}${execi 300 ~/.config/conky/Mirach/scripts/day2dot}
${offset 27}${voffset 20}${font Dosis:size=11}Cpu:${goto 142}Mem:${goto 252}Temp:
${offset 27}${voffset -2}${color1}${font Dosis:bold:size=15}${cpu cpu0}%${goto 142}${memperc} %${goto 252}${acpitemp}°C

and here’s a video showcasing the bug :

using (including things that i think might be useful):
conky 1.18.1_pre compiled 2023-02-24
conky-manager2 v2.73
gnome 43.4
X11 desktop
Nvidia Geforce GTX 1050

(sorry for my english not my native language)
(i might be sleeping when someone respond so sorry if i take too long to respond)

Seems more likely a setting than a bug - conky can appear under, over or beside anything you can display. I would check out the effect of changing the own_window_type to other things than desktop.

Here is a reference page that might help - maybe even with this! :grin:

Thanks for your response
So I’ve tried all the options own_window_type but none of them worked correctly (except panel but this is not what i want, and override just don’t work at all)
If you need any additional info to help ask me !

I am surprised normal isn’t working - I’ll try to find some time before the hoickey game (Stanley Cup playoffs for Toronto Maple Leafs) to see if I can get the problem to appear. Can you post (inside sets of ```) the output of conky -v ? Might give some clues as to libraries.features enabled…

thanks you so much for your time
here is conky -v

Compiled in features:

System config file: /etc/conky/conky.conf
Package library path: /usr/lib/conky

  * math
  * hddtemp
  * portmon
  * IPv6
  * Curl
  * RSS
  * wireless
  * support for IBM/Lenovo notebooks
  * nvidia
  * builtin default configuration
  * old configuration syntax
  * Imlib2
  * OSS mixer support
  * apcupsd
  * iostats
  * ncurses
  * Internationalization support
  * PulseAudio
  * Xdamage extension
  * Xinerama extension (virtual display)
  * Xshape extension (click through)
  * XDBE (double buffer extension)
  * Xft
  * ARGB visual
  * Own window
  * Mouse evenets

 Music detection:
  * CMUS
  * MPD
  * MOC

 Default values:
  * Netdevice: eno1
  * Local configfile: $HOME/.conkyrc
  * Localedir: /usr/share/locale
  * Maximum netdevices: 256
  * Maximum text size: 16384
  * Size text buffer: 256

I don’t have all the pieces to try it out (the lua code for one!) - and so far I can’t find anything that should stop it working correctly. If own_window_type is normal, then the own-window-hints entry for ‘below’ should force things ‘under’ any running apps - as it does for the 19 or 20 conkys I run all the time. AFAIK the ‘sticky’ entry forces the conky to appear on all desktops. I’m running on X11, but my conky is a bit older version (1.11.7 on this machine) - wonder if that matters. Just for comparison’s sake, here is a piece of the config of one of mine…

--# Update interval in seconds.
	update_interval = 1,

--# The number of times Conky will update before quitting.
--# Zero makes Conky run forever.
	total_run_times = 0,

--# Create 'own_window' type. Makes Conky behave like other panels.
	own_window = true,
	own_window_transparent = true,
--own_window_type = 'desktop',
	own_window_hints = 'below,sticky,undecorated,skip_taskbar,skip_pager',
--	own_window_hints = 'below,undecorated,skip_taskbar,skip_pager',
	own_window_type = 'normal',
	own_window_argb_visual = true,

not so different, is it!?

Still looking for now - and trying to find that mess up elsewhere…
You will note that I change the own-window-type to normal, by commenting out the ‘desktop’ entry, and resetting to normal…

All I see so far is problems when using certain hotkeys to switch workspaces - or to ‘show workspace’. I use the XFCE setup on my system, and I spin through workspaces with the mouse wheel, when not pointed at an app - no prob. Still searching…

Oh - and you are using conky-manager to run it? Have you tried running it with the ‘manager’ involved? Much more predictable :grin:

The manager run it by default if i’m not mistaken but if you’re talking about using the manager to turn in on or of for tests, yes and the results are the same

I don’t know about the older version but i’ve seen on this github issue (however discussing about PopOS) that the problem was not about conky but about PopOS (if i’ve understand correctly)
github issue in question :

This was the reason why i made this post, because it may not be a “simple” bug

I guess it could be that (although it claims to have been ‘fixed’) - but how many of those conditions do you meet? What DE, are these workspaces running maximised etc etc… Perhaps you could post the results of inxi -Faz between sets of 3 ` for some more info to work with…

although it claims to have been ‘fixed’

I know but the problem was on PopOS which is not even based on arch and sorry i don’t know what you mean by

What DE, are these workspaces running maximised etc etc…

i’m pretty new to all of this sorry
I’ve also read that the github issue is about DING but this bug also affects Conky so i don’t know
And i’ve not dig into it because again this is a different distribution of linux
but here is my inxi -Faz :

  Kernel: 6.2.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
    root=UUID=f08ab522-64a2-4b63-bc20-949949364147 rw nowatchdog
    nvme_load=YES resume=UUID=0be5cd1a-7e3f-4697-a6fe-f8ab19484428 loglevel=3
  Desktop: GNOME v: 43.4 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 43.0
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH
    serial: <superuser required> Chassis: type: 10 v: Lenovo Legion Y530-15ICH
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: 8JCN56WW date: 11/30/2020
  ID-1: BAT0 charge: 44.7 Wh (100.0%) condition: 44.7/52.5 Wh (85.2%)
    volts: 12.5 min: 11.4 model: SMP L17M3PG3 type: Li-poly serial: <filter>
    status: full
  Info: model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3784 high: 3947 min/max: 800/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3869 2: 3600 3: 3831
    4: 3902 5: 3604 6: 3947 7: 3619 8: 3901 bogomips: 36799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:3e9b
    class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: none
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1c8d
    class-ID: 0300
  Device-3: Bison SunplusIT Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-6:6 chip-ID: 5986:2113 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: eDP-1 mapped: eDP-1-1 model: LG Display 0x05e5 built: 2018
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX
    1050/PCIe/SSE2 direct-render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    bus-ID: 1-2.1:5 v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    chip-ID: 19f7:0015 class-ID: 0300 bus-ID: 00:1f.3 serial: <filter>
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0fb9 class-ID: 0403
  Device-3: RODE Microphones RØDE NT-USB Mini type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  API: ALSA v: k6.2.12-zen1-1-zen status: kernel-api tools: alsamixer,amixer
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 07:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:7
    chip-ID: 0cf3:e500 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.03 TiB used: 40.69 GiB (3.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM128GDHTNG-8310A size: 119.24 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: 80060C00 temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-24Z10
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A04 scheme: MBR
  ID-1: / raw-size: 109.46 GiB size: 107.19 GiB (97.92%)
    used: 40.69 GiB (38.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 288 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 94.0 C pch: 62.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 347 Uptime: 4h 36m wakeups: 9 Memory: 15.5 GiB
  used: 5.85 GiB (37.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1317
  pm: pacman pkgs: 1287 libs: 413 tools: gnome-software,pamac,yay pm: flatpak
  pkgs: 26 pm: snap pkgs: 4 Shell: Zsh v: 5.9 running-in: gnome-terminal
  inxi: 3.3.26

Depending on where the problem actually originates, the different distribution may not matter. Often people find answers in the ArchWiki that allows them to fix what’s wrong on their system, despite it being nothing to do with Arch.

In this case, you are running the same Desktop Environment (DE), just with some setup differences than Pop!OS - which is Gnome 43.4 in this case.

If othing else, you can look for similar happenings on any distro’s version of Gnome.

Pure speculation here, that might help to narrow it down…

  1. I assume you are on Wayland - if you switch it up to X (probably a choice when you log in), does the problem change?
  2. You could try to make this happen with both video cards, and see if there are differences in which you use. Sometimes drivers change, and oddities temporarily ensue.
  3. Sometimes conky’s interaction with different versions of a DE (or, more properly, whatever is managing your windows) can change with different versions. Ensure you can return to your current version - then try an earlier version of conky, and test. You could test where you got it(!) by pacman -Qi conky (mine was from conky-cairo in the AUR) and you may be able to try an earlier version just by sudo downgrade conky and choosing something with a lower version number.

Those, and the general Duck Duck Go search for similar problems (as you found previously), especially occurring on Gnome, may lead you to something useful - or the next update might just fix it! (There is ALWAYS another update arriving shortly on EndeavourOS/Arch!)

I’ll try to look out for stuff too - BTW - have you tried the conky site to see if someone else has seen this with conky? The site address can be seen in the output from the pacman -Qi command, but is probably

Good luck! - and let me know what you find…

Thank you so much for the help, i’ve learned do much from this.
Just to answer your speculations :

  1. I’m on X11 and Wayland is just not an option for me
  2. For what i’ve experienced with GPUs this is one or the other (and if it’s possible i dont know and i’ve not found it)
  3. Tested different versions (like conky-cairo) and downgrade but nothing have do it.

Thank you for the github too, i nerver think to check those !
I will update you if i have any other updates

Edit 1 : I’ve searched through the github issues and not found anything (either no one posted about this or i dont have searched for the correct name)
Edit 2 : added 3.
Edit 3 : added 2. And i feel like i sound so picky but i prefer have a solution without sacrificing anything (because it’s a small problem overall)

This value should be set to ‘override’, in order to make conky stay in the background. Just found that out myself, since my old conky, working without any issues on Gnome, Xfce, Kde - suddenly on an i3wm-install puts itself on top of other windows. :wink:

own_window_type = 'override',


Sorry but i’ve tried that and conky doesn’t display anything and i don’t know why

Sorry to hear this. :frowning:

As I didn’t want to read the whole thread again, just now… do you have a composit-manager installed? If not, it could be worth a try. I use picom on KDE and i3. It can be started per session with picom -b.

Using Gnome i have the gnome-shell v: 43.5
I got it using the command inxi -Gxx and looking at the compositor line
Should i change it ?

I guess not. You should better read and study the link I posted last for composite-manager if you wish. :wink:

I have also once tinkered with Conky had saved me the external Lua.configs but always. Anyway.
I never used the conkymanager. Why also.

I can’t test your config because it is incomplete.

To find errors better you can start the config from the terminal.
conky -c /$HOME/Documents/test_config.conkyrc

This way you can see any error messages we might need.
You can always abort with Ctrl+c and or
killall conky
at any time.

Just a thought: Gnome uses Wayland by default and you have to select x when logging in. I don’t know exactly but isn’t Xwayland used as a replacement for a real Xserver?

Settings I would try I found in the manpage.

              Open a Wayland window to display output.

              When set to no, there will be no output in X (useful when you also use things like
       out_to_console).   If you set it to no, make sure that it's placed before all other
              X-related setting (take the first line of your configfile to be sure).

Just for fun, I would see if I can use the entry
out_to_wayland = 'true',
I would have more success.
Nvidia is set to $DISPLAY by default and should be irrelevant.
That’s all I can think of at the moment.