Conky always on top of other windows in KDE Plasma 6.0.2

Since upgrading to KDE Plasma 6.0.2, conky is now always on top of all windows when started.

I have this set in my conky config file but it appears it’s no longer being ‘respected’ with KDE Plasma 6.0.2

own_window_hints = 'undecorated, below, sticky, skip_taskbar, skip_pager',


Have you tried removing “sticky”. I know it’s only supposed to make sure the conky is on any desktop/workspace, but try it all the same.

Not sure if you’ll need to log out and log in. Wayland be weird.

Yes, thanks. I had removed it without logging out and tried it again by removing it and then logging out and back in again. Same issue. :frowning_face:

I had the same problem on Plasma 6. The solution is to create a custom setting in System Settings >> Window Management >> Window Rules. For the record, I start Conky with a script so you will have to adapt your rule for your situation.

Rule name: Conky
Description: Conky
Window class (application) - Exact Match - Conky
Match whole window class: No
Window types: All selected
Virtual Desktop: Force - Desktop 1
Activities: Force - Default
Keep below other windows: Force - Yes
Skip taskbar: Force: Yes
No titlebar and fram: Force - Yes
Focus stealing prevention: Force - None

I should also add that this rule works when running Conky with

own_window_type = 'normal',

in your Conky configuration file.

I haven’t moved on to Wayland yet so your mileage may vary with this setup.

Thanks. I had high hopes for this solution, but alas, no luck. Same issue with appearing on top of every window after setting up this rule.

I also start conky with a script.

Me too.

Anyway, are you using Wayland for any specific reason? If not, you still have the option of using x11 for now. Wayland is still not yet the standard and, as you are experiencing right now, it still has some kinks to iron out.

Another option (maybe) is to find out if there are Wayland-based conky alternatives.

Interestingly, I’m getting the same behavior where Conky stays on top of all windows when I switch back to X11 as well.


1 Like

That’s sad.

I think that this may be fixed more quickly for x11 than for Wayland, but now it seems it may just be related to the whole Plasma 6 update in general.

Try installing Openbox and running Conky to see if the same issue occurs. Openbox is a small install (1250.45 KiB), and you can remove it right after. Just want to test if it’s Plasma6-specific or not.

PS: You can run any of your apps within Openbox without issue, including KDE system settings.

Thank you. Sorry for the delayed response. I used both Gnome and XFCE. Conky behaved as expected and stayed below all windows.

So seems to be a KDE 6 thing…

1 Like

Works as expected here. I have:

own_window = true,
own_window_type = 'normal',
own_window_hints = 'undecorated,below,skip_taskbar,skip_pager',
1 Like

Thank you. Changing own_window_type to ‘normal’ seems to have fixed it. I had ‘dock’ for that value (which worked previously)

1 Like

Also, for my clock, I came up with another plan:

	own_window_class = 'conkyclock',

Then set a separate rule for that class.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.