Conflicting libssl after upgrade

On a fresh install and after pacman -Syu I’m trying to install a lamp stack. I need php7.4 ideally but whether I install php7 and php7-apache or just ‘php’ to get version 8, when I go ‘php --version’ I see:
‘php: error while loading shared libraries: cannot open shared object file: No such file or directory’

On reading the related thread (Problems with and after 2022 Nov 5th updates - #5 by storm) I tried installing libssl-1.1 but get ‘target not found’. Trying ‘sudo pacman -S openssl’ I get:
:: installing openssl (1.1.1.q-1) breaks dependency ‘’ required by libarchive
:: installing openssl (1.1.1.q-1) breaks dependency ‘’ required by sudo
:: installing openssl (1.1.1.q-1) breaks dependency ‘’ required by sudo
:: installing openssl (1.1.1.q-1) breaks dependency ‘’ required by systemd
:: installing openssl (1.1.1.q-1) breaks dependency ‘’ required by systemd

…and thus I’m stuck and could do with some help here. Any ideas please?

hi @psaikido,

welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple:

show the output of

pacman -Qs openssl

local/libevent 2.1.12-4
Event notification library
local/openssl 3.0.7-4
The Open Source toolkit for Secure Sockets Layer and Transport Layer Security
local/pkcs11-helper 1.29.0-2
A library that simplifies the interaction with PKCS11 providers for end-user applications using a
simple API and optional OpenSSL engine
local/xmlsec 1.2.37-1
XML Security Library is a C library based on LibXML2

How about:

sudo pacman -S openssl-1.1
1 Like

error: target not found: openssl-1.1

That definitely should exist.

Perhaps you are connected to an out-of-date mirror. Try resorting your mirrors and then updating your system.


I used the eos-welcome --once thingy and updated the arch and endeavouros mirrors then updated the system. Tried pacman -S openssl-1.1 and get ‘target not found’ again.

What is the first mirror on your list? You can see this in /etc/pacman.d/mirrorlist

Server =$repo/os/$arch

That mirror is out of sync.

Try commenting that mirror out and try updating your system again.

Updated the mirrors with:
reflector -c ‘United Kingdom’ -a 12 --sort rate --save /etc/pacman.d/mirrorlist
…and now have mirror:$repo/os/$arch

After a ‘sudo pacman -Syyu’ I now can install openssl-1.1 with:
sudo pacman -S openssl-1.1

…and thus php -v reports correctly. I’m detailing this in case someone trips over the same thing. Thanks for your help :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.