Configuring the menu in Cinnamon

I would like to change the width of the menu a little bit since it occupies a rather big piece of space on the screen. Right-click on the menu icon and choosing configure, I haven’t seen any settings related to this. In Xfce where I come from, this is done easily by pulling the corner of the Whisker menu to resize it. Can this be done by editing some file(s)? I appreciate any pointers to solving this.

I came across this, seems like it’s maybe not as easy as it is in XFCE…

https://forums.linuxmint.com/viewtopic.php?t=283147

1 Like

It is not unfortunately. There are alternate menus however. Search through applets.

1 Like

You can do it, but you will have to download the source code for cinnamon, change what you want, compile it, and install your own customized cinnamon version, and then you have to maintain your own personal fork.

1 Like

@pebcak
Can you explain this a little more as I’m not sure i understand what you mean. Do you mean the actual Menu in the taskbar?

Edit: I think you mean this?

https://forums.linuxmint.com/viewtopic.php?p=1563189&sid=d8075ece23ccd6cd0980768b7fc46acb#p1563189

2 Likes

Thanks @alenbasic, @alenbasic for the links!
I will look at the solution presented there and see if I can make it work here as suggested.

@Elloquin, I will look into other options through applets as well. I had already installed Cinnamenu but I haven’t explored it yet. Thanks for your suggestion!

Thanks @plgonzalezrx8!
It is beyond my current level of understanding codes to dig that dip into the Cinnamon menu’s but sure, your suggestion make sense but I am not sure if I can make sense of all those lines of codes. Perhaps sometime in the future. Hopefully.

Thank you all! The solution presented in the link worked for me.

  1. Copy the folder /usr/share/cinnamon/applets/menu@cinnamon.org to ~/.local/share/cinnamon/applets/menu@cinnamon.org

  2. In the local copy open ~/.local/share/cinnamon/applets/menu@cinnamon.org/applet.js in a text editor.

  3. Navigate to line 32 const MAX_BUTTON_WIDTH = "max-width: 20em;"; and reduce the value of 20 (10 works good).

In my file it was on line 30.

I’ll mark post #2 as solution (sorry @ricklinux! @alenbasic was first. :blush:)

5 Likes