Computer startup problems

Hello to everyone who comes here to help, first of all I would like to thank you for the future answers in the topic.

– The problem –
I use a dell inspiron desktop 2013 recently left windows and went back to arch and the chosen of the time was the EOS, everything was going very well until I noticed that the screen that should appear at system startup in which I could choose to access the bios no longer appeared and nor responded to my commands.
Since then I have not been able to install another system as I cannot access the bios. Yes I have already pressed the keys that should do the job but it does not work. The system works normally but the bios does not respond and the grub screen does not appear either.
I know that the problem has no connection with the EOS but I have been helped before with several topics present on the forum and I know that you can help me once again.

I’m sorry for any problems related to possible grammatical errors, I don’t speak or write English fluently.

From within your system, open a terminal and run the following command:

systemctl reboot --firmware-setup

This will reboot your system and hopefully get you into the bios.

Also the following info might help forum members to have some idea about your setup.

test -d /sys/firmware/efi && echo efi || echo bios

sudo parted -l

cat /etc/default/grub

inxi -Fxz

Copy and paste the terminal output and use the </> button to format.


If the above method fails for some weird reason, you may use old school hard reset, as your user manual would explain:

[victor@archdell ~]$ test -d /sys/firmware/efi && echo efi || echo bios
[victor@archdell ~]$ sudo parted -l
[sudo] password for victor: 
Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name  Flags
 1      2097kB  317MB  315MB   fat32                 boot, esp
 2      317MB   491GB  491GB   btrfs           root
 3      491GB   500GB  8861MB  linux-swap(v1)        swap

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 15,4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  15,4GB  15,4GB  primary  fat32        boot, lba
[victor@archdell ~]$ cat /etc/default/grub
# GRUB boot loader configuration
GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=51eff4f8-010f-4bb9-b491-f87dccf679de loglevel=3 nowatchdog nvme_load=YES"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

# Uncomment to disable submenus in boot menu

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
[victor@archdell ~]$ inxi -Fxz
  Kernel: 5.17.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: KDE Plasma v: 5.24.5 Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: Dell product: Inspiron 3647 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 02YRK5 v: A03 serial: <superuser required> UEFI: Dell
    v: A04 date: 04/03/2014
  Info: dual core model: Intel Core i3-4130 bits: 64 type: MT MCP
    arch: Haswell rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 2115 high: 3392 min/max: 800/3400 cores: 1: 3130
    2: 1054 3: 3392 4: 887 bogomips: 27145
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics
    vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: intel
    unloaded: modesetting gpu: i915 resolution: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
    v: 4.6 Mesa 22.0.2 direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:03.0
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.17.5-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel port: e000 bus-ID: 03:00.0
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Dell driver: ath9k v: kernel bus-ID: 04:00.0
  IF: wlan0 state: down mac: <filter>
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:8
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 480.08 GiB used: 4.76 GiB (1.0%)
  ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade
    size: 14.32 GiB
  ID-1: / size: 457.21 GiB used: 4.76 GiB (1.0%) fs: btrfs dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 576 KiB (0.2%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 457.21 GiB used: 4.76 GiB (1.0%) fs: btrfs
    dev: /dev/sda2
  ID-4: /var/log size: 457.21 GiB used: 4.76 GiB (1.0%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: partition size: 8.25 GiB used: 0 KiB (0.0%)
    dev: /dev/sda3
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): cpu: 1016
  Processes: 209 Uptime: 2m Memory: 3.75 GiB used: 1.8 GiB (48.1%)
  Init: systemd Compilers: gcc: 11.2.0 Packages: 902 Shell: Bash v: 5.1.16
  inxi: 3.3.15
1 Like


Could you please edit your post, highlight the pasted text and click on </> to format for better readability?

1 Like

You could try to edit the /etc/default/grub and change the following line:




Also change:




and run the following to update the Grub:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot and see if you can get back the Grub boot menu.

You could also give:

systemctl reboot --firmware-setup

a try to see if the system reboots into Bios.


Also, it looks you haven’t updated your Bios for a long time:


And how would I do this update, can I do it using linux?

Please report of success or failure of any of other suggested things in my previous post.

1 Like

Not sure where you found the Bios updates but i see there is actually a version A11 dated 31 Jul 2019.

1 Like


1 Like

Sorry i was looking at the older versions image and didn’t notice the A11 above it. It’s late here and i should be paying more attention! :rofl:

1 Like


1 Like

Can’t sleep for some reason. Feels like it’s morning but it’s not! :sun_with_face:

1 Like

A similar problem has been posted on the Dell community in the past.

1 Like

For now, as the computer is working and I need it frequently, I will not open it to do the procedure mentioned in the links above.
Thanks to everyone who got involved and tried to help. :purple_heart: :purple_heart:

As @Shjim would say: your machine, your rule

However a bit frustrating that you never gave any feedback on the suggestions made in the thread.

Have a good day!


I apologize for not giving feedback, I made the suggested changes in /etc/default/grub and ran the command systemctl reboot --firmware-setup but unfortunately they did not have the expected effect, the screen went black during the boot as if it was working but there was no video.
The screen turns on only when the EOS boot process starts.

1 Like

Thanks for getting back with the info!

1 Like

I appreciate all the help and willingness to solve my problem.
Thank you very much!!!

1 Like