Computer sometimes freezes, SysRq does not work, nor does praying

I have had this bad boy for 6+ years. It is not the most high end machine ever but it is pretty good. I am currently on E.OS, using GNOME as my main interface though I keep XFCE as an alternative.

but lately, and by lately i mean since late August, my computer occasionaly (about every once in a few days, sometimes a bit less often. i use my pc almost daily and it doesn’t Always happen.) freezes completely, usually like after a few minutes of runtime, and I cannot do anything except hard reset/reboot. REISUOing does not work, nothing is responsive, even if i plug in my Wacom it won’t recognize it (its led doesn’t turn on). when i turn the device off and on again it runs fine for as long as i need it {it does a little fsck on bootup, and so far nothing has came out of it}. checking on journalctl is futile; there are never relevant Logs from around the time of the freeze.

I am pretty sure this is a GNOME problem because so far it has only happens When I’m on GNOME. (even tho ive been using “the G” since at least late spring, before the freezings started happening) i think it might be related to some grapical glitch or something, like i open too many windows too fast or my cursors slips to the wrong place a t the wrong time or something? im not sure how to explain it: last time it happened (a few minutes ago), i was on the terminal, i did a flatpak and a yay update like always, i close it, so far so good, but the second i Open Google Chrome (like immediately after the window pops up), the thing has a stroke. sometimes i manage to use GC for a few minutes (like open a few tabs) before it crashes. [note that i dont believe that this is a google chrome problem, because it also did this back when i was still using firefox. some other time it froze i wasnt even trying to open a browser] I’m sorry if my examples are not very helpful but it seems to me that it freezes at random without warning and with no indication as to what triggers it.

one time, i went straight to the xfce session, adn as the system was updating (the terminal was open) i had a different window open with a game to pass the time. a short (like 1 second) freeze happened, but the thing went on fine and i used the pc for hours normally. which, i think, reinforces my theory that maybe GNome is not doing something right. like it cant handle a small lag and so it hangs the whole system. but like i said it wasn’t always like this. so, idk.

I do not believe I have a problem with my RAM or anything like that, last time i did a memtest there were no errors. I use the latest linux-lts kernel which i update regulary, intel graphics (no nvidia), no fancy extensions, wayland session always. if anyone has any clue as to why this is happening, let me know.

1 Like

Hello, One of my machines (B460, i5 10400f, gigabyte) was a bit acting like that. I updated the 2½ years old BIOS for the latest and it went away …

I do not believe I have a problem with my RAM or anything like that, last time i did a memtest there were no errors.

For what it’s worth, I experienced the errors you listed for about 3 months - frequent crashes across 3 different browsers even with just 2 tabs open, random freezes when copying files, random freezes when using the laptop normally, random freezes and crashes when leaving the laptop on idle… you name it. It happened on Windows, happened in EOS Gnome after a few months of use, Memtest never alerted me of any errors so I thought it was something else too. Last month I gave in and replaced the non-soldered RAM stick I have, bam, my system has never crashed since.

(Of course your issue may very well not be faulty RAM but I wouldn’t completely rule it out either!)

Add.: Also on LTS kernel, Intel UHD 620, Wayland only, then and now.

now that you mentioned BIOS i wanna talk about a different issue that may or may not related to my post’s issue.
sometimes, when i shutdown the os, after the systemd end credits roll and the screen turns to black the actual computer is still running; it doesnt power off completely. you can still hear noises and the small light on the side is still on. i have to press the poweroff button manually to power the computer off completely (like the days of old when windows would tell you “it is now safe to turn off your computer”). it hasnt happened in a while but, like the freezes it occurs quite randomly and some nights when i forget to check the pc just stays idle for hours, and the next morning it is warm.
not sure what causes that either (cant recall when it started doing this, probably less than a year ago but im not siure) but could these two problems be related? maybe i should update the bios (“uefi” actually)(i dont know how to do that) or try a different ram like the other guy suggested?

In the pool of calculating PCs, two of them are doing exactly that. The one that has an ASUS 410 chipset with i3 10100f, and this one the Gigabyte B460 with i5 10400f. They’ve been doing this for a long time, so I do just like you I press the off button when I do the rotation in the morning. The other 17 don’t do this :wink:
(All software is up to date, BIOS, OS, and voltages are good.)

Edit :
To learn how to flash a BIOS: They are a lot of information with videos on the web and in written format on the manufacturer’s web page. You need a good USB drive in general, where you will unzip the new software … )

The professionals in the trade of computers have sometimes working protocols that will force them to put a UPS on the machine before they will flash ( they can loose their job if they don’t and kill a motherboard … ) - because: if an electric grid problem arise you may loose certain of them while you are flashing. I did this when I was deployed or in a country with frequent electric shortages.
Here at home I just do it without …

turns out, it can also do this on the Xfce session as well. It’s so Joever

What is your hardware? Post the link

inxi -Faz | eos-sendlog


Did you actually find out if there is a newer bios update? Current version v: F.02 date: 05/24/2018

I Checked on Hewlett-packard’s web site and apparently thereis a new BIOS update (F.46 Rev.A, for Intel processors, release date: Aug 28, 2023).
idk I am not quite sure how to actually update it tho. I have no access to a Windows machine atm and I cannot afford to nuke the computer right now, as my semester has just started and also i have zero money

Just make sure it is the correct UEFI Bios for the right model and serial number. You could use the Hirens boot disc and create a boot-able usb disc that would allow you to boot on and update the Bios. Since you need the system you may want to wait until school is finished. You need to understand how to do it properly and things can go wrong. This is how it can be done though.

so, let me get this straight.

  1. i boot up this windows live image thing.
  2. i go to hp’s website, and find the .exe for my bios.
  3. i run that shit and create a bootable usb with the update
  4. i Boot from the BIOS USB and perform the update,
  5. Inshallah this works and my computer doesn’t die
  6. profit.

is that It?

btw i just remembered a minor detail that may or may not be important. in the beggining of this year ,or maybe around last christmas, i got a new battery for my laptop because the old one was running out of juice too fast. However, I was a bit short on cash that day so i got an unnoficial batttery, (not the HP approved one). my pc did complain a bit at first and i did run into a small problem but i managed to fix it after chrooting and it all worked out without losing any data.

should this impact the bios update, like will it complain that my battery isn’t “legit”? or something