Computer logs out when screen saver starts

Every time gnome goes to sleep or rather the screen locks rather than locking it logs me out. I’ve tried turning off all extensions, which didn’t work. I also tried creating a new user and as soon as I locked the screen I got logged off. Any suggestions on how to fix this?

2 Likes

are you sure it goes out the session, or does it simple lock session and ask for password to unlock session?

2 Likes

Can you give a little more information? Are you using wayland, xorg, etc. Gdm, light-dm, sddm, etc?
Let’s take a quick look and see if there’s any obvious journal errors. Run it after it exibits this bahavior and you are logged back into your desktop.

In terminal do:

journalctl -p 3 -xb
Don’t worry this command does not show any user data. Copy and paste the output here with three ``` before and after. Or use the </> button up above.

2 Likes

yes I’m sure its the session and not simply the lock screen

1 Like

Hope this helps:
DM: gdm 3.36.3-3
DE: gnome 3.36.4-1
display server: Wayland 1.18.0-2

the logs were too bit to put here so I put them on ix.io
http://ix.io/2u3c

@galvez_65 - are you just being logged out, or is your system rebooting. I ask this because I think I am seeing similar behavior on my laptop, but in my case I think my laptop might be going into screen saver then rebooting to the launcher. I have an almost identical setup:
DE: Gnome 3.36.4
DM: GDM 3.36.3-3
DS: Wayland 1.18.0-2

1 Like

mine is not rebooting, just logging me out. what happens when you lock the screen from gnome? when lock the screen the lock screen pops up momentarily, it then goes blank and I am back at the gdm login screen

1 Like

I have a different issue, if I hit hotkey+L to lock the screen I get a kernel panic (I think that’s what the flashing light on my caps lock key means). I’ll follow along on your thread for informational purposes but will need to go open a different one for my issue.

Good Luck!

Does it exhibit the same behavior if you don’t use wayland?

not sure, I will give that a try later tonight after work and report back.

@Elloquin it only happens with wayland not xorg
I reran the logs incase they are of any help
http://ix.io/2u5U

Well then you may just have to use xorg. Is there a reason you need wayland?

no specific reason, other than I like the idea behind it. The odd thing is that it was working fine a couple of months ago. Don’t really remember when this became an issue but I have just been noticing it more now. Unless someone sees something in the logs that can help debug this more I may have to go with X just continue to keep an eye on wayland.