Compositing Not Working

Selecting or Deselecting to enable or disable compositing in XFCE has no effect. I have checked to make sure that xfwm is running, and it is. No matter what settings I change, there is no effect. I’m sure there is something I am missing that is very simple and any help would be GREATLY appreciated.

Welcome @windowlicker !
Although I have no idea what graphics card you use and other things …
Take a look at this:

https://forums.linuxmint.com/viewtopic.php?t=297222


https://forum.xfce.org/viewtopic.php?id=5490

So you’re asking that:
lspci -nnk | grep -i "VGA\|'Kern'\|3D\|Display" -A2

windowlicker, execute this via copy’n paste in a terminal and post the result here as preformatted text!

My apologies, I should have mentioned that I am running Intel graphics

ouput of
`lspci -nnk | grep -i “VGA|‘Kern’|3D|Display” -A2’ :

00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
	Subsystem: Lenovo UHD Graphics 620 [17aa:2258]
	Kernel driver in use: i915
--
3d:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
	Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:0010]
	Kernel driver in use: iwlwifi

What lenovo product are you using? What exactly is happening with Graphics?

I’m using a brand new T480s and compositing is just not working. Whether I check or uncheck the box to enable compositing or change any settings, nothing happens.

Can you post dmesg log?

hi !

open terminal , and do

pacman -Qs xcompmgr

if its installed you see at .xprofile its on start i believe, add # before xcompmgr will fix it. or remove it

xcompmgr is installed in standard to fix the tears for some, but its loaded in .xprofile , it can collide offcourse with compositor for xfwm4 and make it slowish of that but adding # infront of that you will use the compositor of xfwm4 fully currently i believe is xcompmgr in play.


https://wiki.archlinux.org/index.php/Xfwm#Tips_&_Tricks

on the iso s standard set to xcompmgr to .xprofile , setting the xfwm4 on or off wont help much this case or kwin…

I have it on my system but i have Radeon HD graphics. No problems.

[rick@xfce-pc ~]$ pacman -Qs xcompmgr

local/xcompmgr 1.1.8-1
    Composite Window-effects manager for X.org
[rick@xfce-pc ~]$ 

Screenshot_2019-11-10_11-26-53

in this case it can be variable for some works and some not… but i think regular user wil look intoo the xfwm4 settings but select and de-select dont work, xcompmgr is just loaded by start , killall xcompmgr wil notice difference shortly

If you comment out the file it kills the compositor all together. Is this different than turning it off?

two different compositor can have different behaviour at the end. on telegram someone had issues atleast, and removed the line with xcompmgr fixed with xfce also with kde .

1 Like

So last night I tried for hours to fix the issue to no avail. So, I got rid of the Endeavor install and installed Fedora. However, I would MUCH rather use Endeavour as Arch is what I am the most familiar with. In the next few minutes, I will re-install Endeavour and let you guys know if commenting out that line in .xprofile works for me.

Btw, I also tried installing SDDM and Plasma last night, after logging in, any application I launched, would open, however, none of the windows were visible.

Try the August ISO and see if you have the same problems. Don’t worry about the older install, as soon as you do a sudo pacman -Syyu everything will update. I did this and installed KDE/Plasma with no problems.

So, I just finished with the Endeavour install and commented out that line in .xprofile as well as killed the xcompmgr process. Then I unchecked and re-rechecked the Enable Compositing box in Settings and compositing is now working. I knew it had to be something simple, and it was. Thank you so much for all of you guys help. I can’t tell you how much happier I am to be back on Endeavour.:smiley::smiley::smiley:

3 Likes

Question: Is .xprofile only created for Xfce? I don’t have such a file with KDE/Plasma.

.xprofile is not only for xfce , is i think more for the display managers and x? when starting it calls those files lightdm, but sddm im not sure…