Completely Reset Pulseaudio/Pipewire

Ever since I switched from Pulseaudio to Pipewire(a long time ago), Runelite has no audio. I installed it in one of my recent VMs which installed with Pipewire as the default and turns out I can see it in the mixer outputting sound.

Obviously on my install, I still do not have sound. I have tried various things over the months/years like completely nuking runelite and re-installing it.

Could there be an underlying pulseaudio config somewhere that is causing issues? I feel like that might also be the reason why windows VMs can output sounds, but not Linux VMs unless it takes over my sound output muting the host system. It feels kind of stupid of going through the troubles of making a clean install just to get this working properly.

It turns out that deleting ~/.asoundrc solved the issue. I found this in the PulseAudio page of the arch wiki. Oddly enough this has no mention at all on the PipeWire page. Turns out scratching my head at the issue when I should have been asleep a long time ago worked out nicely for me today.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.