Completely Get Rid of Borders

So I’ve read the i3docs , sway has nothing on it (nothing I can find) and I’ve looked at many forum posts but nothing seems to work for me. I don’t really like asking on forums before trying stuff before myself, but now I have no other option.

I’m trying to get of the border of one my windows when it pops up.


for_window [app_id="avizo"] floating enable, border normal 0, border pixel 0,

The thing I’m guessing I need to change is the stuff after floating enable… but what too? Nothing I’ve tried worked yet.

border_images.focused ~/.config/sway/borders/focused.png
border_images.focused_inactive ~/.config/sway/borders/focused_inactive.png
border_images.unfocused ~/.config/sway/borders/unfocused.png
border_images.urgent ~/.config/sway/borders/urgent.png

I do realise that second isn’t very helpful but that’s how my borders are coloured in focus and out. Is is something to do with this?

2021-01-12T16:52:43,035017360+00:00

I want there to be no border or titlebar on that window. Thank you!!

1 Like

Not sure about the border but this will remove ALL titlebars…
for_window [class="^.*"] border pixel 1

1 Like

In my config I have a note

# Configure border style <normal|1pixel|pixel xx|none|pixel>

So try border none.

But this is i3-gaps.
Also for an already opened window (with qwertz keyboard)

# change borders
bindsym $mod+z border pixel 1
bindsym $mod+u border none
bindsym $mod+i border normal

Thank You however unfortunately it didn’t change anything. I’ve studied the i3Docs and I saw that however no matter why combination I try nothing changes.

Are you sure this is correct then? Sometimes it requires case sensitive values.
I would start with

default_border none
default_floating_border none

So every window will be without borders. If that works then I would chage it per application.

Also, did you restart your i3 session? It may need to reload the config file.

I definetly reloaded it so now i’m wondering about my app_id is there any tool you know off I can use to find it?
I’ll try the other things meanwhile

xprop
my old post

or according to arch-wiki

To get only the app_id's of all open windows use:
swaymsg -t get_tree | grep "app_id"

But it may not be as simple

If the app_id happens to be null for some windows, you might have to use the class and/or the instance attributes to enable floating mode/window assignments. You can search the output and create fine grained rules for your windows.

~/.config/sway/config

for_window [app_id=“galculator”] floating enable
assign [class=“firefox”] -> 3
assign [class="^Urxvt$" instance="^htop$"] -> 9

Wow thank you for the information! I shall look at it tmrw and report back.
Now I’m annoyed I didn’t check the arch wiki! Of course it has something in it

Thank you for that! The add id was wrong but after some more reasearch the problem was with my particular fork of Sway and an issue with it.
If you are interested, the fork SwayWM borders use pictures as borders or techinally it layers an image on the border, so the border is still there. So even if I remove the border that image is still there. I just have to find a way to exclude the image from the app.

1 Like

That sounds strangely complicated. :grinning:
I am glad you were able to figure it out.

1 Like

Or make the image transparent in that app’s case - if that is possible. No idea what settings are available there…

Hmm you’ve got my attention I shall think about that