Compiling stopped, partition full. 10gb increase in SSD even with removal?

I was compiling Librewolf, I saw the memory being taken up kept going up, nearly 10gb until the partition ran out of space. The build stopped and removed the packages, but the space is still maxed out in the partition.

I know LW normally takes up a GB, does compiling something really temporarily take up so much space? The program doesn’t exist anymore in my EOS, so I’m not sure what’s going on.

It was probably building in a tempfs mounted in memory. I am not sure what you are using to determine it is full but you could always reboot to clear it up.

Also, a browser is a truly massive application to compile from source. It will need a good amount of memory and space to build. You may need to change your build location to physical disk where you have more space.

1 Like

Thanks dalto. As a side note, how can I stop compiling and undo all packages mid-compiling if I run into this situation again? Tried looking it up but couldn’t find the commands.

Another quick issue, i installed simplenote on Plasma, and when i click the program, it bounces around loading on the cursor but doesnt actually open. One time when i clicked several times on the icon it opened and worked fine, but i haven’t been able to reproduce it opening.

I tried running in Konsole, the executable and i got this error, which i typed the suggested fix for in a terminal in that directory, which did not solve the issue

(simplenote:5378): Gtk-WARNING **: 14:12:38.008: Theme parsing error: gtk.css:1649:16: '-gtk-icon-size' is not a valid property name

(simplenote:5378): Gtk-WARNING **: 14:12:38.008: Theme parsing error: gtk.css:1652:16: '-gtk-icon-size' is not a valid property name
[5378:0412/] This is frequently caused by incorrect permissions on /dev/shm.  Try 'sudo chmod 1777 /dev/shm' to fix.
sudo chmod 1777 /dev/shm

Did you try ctrl+c in the terminal you were running the command in?

1 Like

I don’t believe so, thank you for the heads up!