Command 'grub-install --target=i386-pc --recheck --force /dev/nvme0n1' returned non-zero exit status 1

Hey there, thanks for the project, it’s looking good.
The other day I installed Endeavour and all was well, no install issues but I wanted to change DE, and I figured it would be cleaner to reinstall first. So, I went back to the live boot from USB and went through calamares, but I got this error:

Command ‘grub-install --target=i386-pc --recheck --force /dev/nvme0n1’ returned non-zero exit status 1.
Installing for i386-pc platform. grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won’t be possible. grub-install: error: embedding is not possible, but this is required for cross-disk install.

File “/usr/lib/calamares/modules/bootloader/”, line 457, in run

File “/usr/lib/calamares/modules/bootloader/”, line 429, in prepare_bootloader
install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/”, line 340, in install_grub

File “”, line 6, in

Installing to the same drive, same everything. Any ideas why it no longer will install? Seems like a grub issue, but it was just working?


Edit: Ok I feel like an idiot, my bios reset itself at some point, switching me out of efi mode. Duh. I’ll leave this up in case anyone else out there makes the same mistake, unless a mod wants me to take it down.

1 Like

I just got nearly identical messages and can’t install, but this old PC has no EFI, nor did the installer ask, and I didn’t flag any partition as EFI.

Also: this was my second attempt, and wanted to keep my /home/username drive, but that install also failed because “User NAME already exists!”. I have it backed up, though, so told it to format it to escape that problem, just to get this one now.

Guy’s, late at night, and I might be misunderstanding here, but ordinary Arch based distros won’t install on 3.86, since it has been abandoned.


There are a few Arch based systems that supports it, and I think it might be a Manjaro spin out there.

It’s not I386, it’s an X64 system but without EFI. had Antergos and Endeavior on it before, no problem. The message says I386 for some odd reason, maybe they just didn’t update the messages.

First off, I am going to start with the very basics that more than one person has not realized. If you already know all this, please don’t be offended.

The EndeavourOS ISO installer can be launched in one of two modes, msdos/MBR or UEFI.
When you boot up your computer, you need to tell BIOS to present the Boot Menu, which is F11 on my computer. BIOS will then give you a screen with the possible boot options.
I have the EndeavourOS ISO on a Lexar USB FLash Drive 1100, so the boot menu gives me the two following lines, plus a few more,
USB: Lexar USB Flash Drive 1100
UEFI: Lexar USB Flash Drive 1100. Partition 1

To boot into the msdos/MBR installer, the first entry prefaced by USB: should be chosen.

Then you should get a blue screen with a big EndeavourOS logo and name at the top.
If you get a black screen with white text, you are in the UEFI mode and need to re-boot.

This should allow Calamares to properly run grub-install.
If you have properly started the ISO and still get the above error, you are in territory beyond me.

Good Luck, hope that helps.

1 Like

Are you able to boot on the live ISO and install inxi and then post

inxi -FGz

Yeah, I know all that, as I said this box is 64 bit architecture AMD Athlon Phenom 4core 8 threads DDR3…, but prior to EFI, so it’s a legacy BIOS (Been computing since 1979) and know all my boxes in and out. I had Endeavour on it already, but was going to reinstall, to use the PC in a slightly different configuration and for a different purpose (Backups and file server). I also set the BIOS to default settings,accept for enabling AHCI, as that needs to be done prior to install.

Something tells me there’s something wrong with the calemares config files. It is either not writing my partition choices to them, or something. I have tried every combination of setting the boot flag, once on each partition, on one partition per drive, on all partitions (it let me do that) and even didn’t set one at all: all installation attempts give the same error:

it doesn’t care what I do. Now I am going to just let it install everything where it wants, and if that works, I will have to reconfigure the partitions and mount points to my liking later, the hard way.

Wish me luck! :stuck_out_tongue_winking_eye:

1 Like

Good Luck!
Let us know what happens. I have an old computer with similar specs, if I remember correctly. If it doesn’t work I will try a test install on it and see if I can recreate the problem.



The last ISO release had a newer version of calamares than the previous ISO. So you may be correct. I might just get that old computer out of the parts closet and try it anyway if I find time.

I got it installed. Didn’t like GPT on that machine for some reason. Other drives on it are GPT and it reads them fine!

1 Like

GPT disks are not good at handling MBR/BIOS boot. They are meant for UEFI boot.
It is possible to use GPT disks with MBR/BIOS boot, but requires a small extra partition for that, and the partition needs bios_grub flag (if I remember correctly).


I never tried that, but it makes sense. :thinking: I must have just got away with using GPT without the OS on one, from moving drives around between PC’s. They do work for storage. :sunglasses: