Clamtk gets stuck and closes

Hello friend.

I installed yay -S clamav, then I installed yay -S clamtk (cronie version), then before starting it I ran sudo freshclam, and then I started clamtk from the start menu.

The problem is that when you click UPDATE or try to scan a file or directory, clamtk stuck closes.

I don’t know if I skipped any steps or did something wrong.

I am on EOS KDE 6.0 with nvidia (proprietary drivers, I don’t know if it could be the fault of the nvidia drivers or something like that).

Thanks in advance.

Yeah ClamTK don’t work, you can’t update with it.
I’ve gave up on it and just run ClamAV in terminal.
KDE 6 and driver have nothing to do with it ClamTK is just broken.

1 Like

I’m using Cinnamon, I’ve got a AMD video card. I’m using Clamtk which I ran just for the fun of it this morning. I’ve got 6 windows program files on my computer which I run through ‘Wine’. I also have them stored in my home directory in a folder named ‘Software’.

Clamtk: version 6.14
clamav: 1.21
Antivirus Signatures as of today : 27,232 loaded
Here’s what I came up with scanning my ‘Home’ directory after checking all under :‘Settings’.

files scanned: 56,272
possible threats: 11

I did analysis of all 11 threats and nothing came up as suspicious.

It works fine and does not lock up. . . maybe your issues somehow conflict. Try removing everything and re-installing and running just Clamtk.


1 Like

Have you tried running it in Xorg just to test?

EDIT: Just installed clamav, clamtk and updated freshclam in Gnome Wayland, ran a scan on my /Downloads without any issues.

1 Like


Just out of curiosity, what is your use case for clamav/clamtk?

Do you run a file/mail server? Do you often share files with Windows?

To my understanding, ClamAV is not an antivirus solution for Linux systems.

Clam AntiVirus is an open source (GPL) anti-virus toolkit for UNIX. It provides a number of utilities including a flexible and scalable multi-threaded daemon, a command line scanner and advanced tool for automatic database updates. Because ClamAV’s main use is on file/mail servers for Windows desktops, it primarily detects Windows viruses and malware with its built-in signatures.


I installed the packages, then

sudo freshclam

Clamtk works fine, but you could first test Clamav itself before using the GUI (Clamtk) :

clamscan .bashrc 
1 Like

Clam is utterly useless, in my opinion. Why would I waste even a single CPU cycle trying to protect some windoze system from malware, especially given the fact that windoze itself is malware?

All windoze antivirus software is pointless, when you think about it, but one that runs on Linux doubly so. If windoze users cared about malware, they’d be using a different operating system, one that is not malware itself.

1 Like

There are signatures for Linux malware you can add. I also don’t think it’s useful, though. The router firewall, some adblock and browsing respeonsibly should negate any threats that could get you on Linux.


Hi friend. I think I’m going to do the same.

Do you know if it is very difficult to use clamav from the terminal?

Thanks Friend, tomorrow I will try to delete both and install only clamtk. Maybe it will work.

I’ll try it tomorrow, thanks for the idea, I hadn’t thought about using xorg.

Hi friend. I’m downloading Windows games and using them with Wine using Lutris and Heroic Games Launcher.

Most people say that it is possible for Windows viruses to affect my EOS using Wine, since Wine is not an emulator.

So, I would like to prevent this if possible. Maybe clamav doesn’t have the best detection level, but maybe it can detect some of them.

I know I shouldn’t download unreliable games but they run better on EOS than on Windows 10.

Thanks friend, I’ll try this!

Hi little cute frog. So you mean, if I run an .exe through Wine, my EOS won’t get infected? Even if it’s ransomware, or a keylogger or something?

Hello friend. Yes, I’m guilty on that one, I’ve run a lot of games.exe. Could I be infected since I ran them through Wine?

I have never used my EOS password to install anything, only for the Arch/Aur repositories. But maybe some of those .exe games had viruses.

Then better use an anti malware for Linux like LMD (maldet package).

1 Like

Thanks to all friends.

I did it, and it worked! I put wayland back on, and it stopped working…

Does it mean that my pc doesn’t support wayland because my gtx 1050 ti is old, or is it that clamtk is very old and only works with xorg?

So sad… I hope to buy an amd graphics card soon, although I suppose that won’t make the programs work in wayland, will it?

1 Like

Of course it won’t. You having a new graphics card, as great as that is, won’t suddenly make Wayland any good. It sucks and it will continue to suck.

clam av was born to be messy and I don’t like to hassle with it and there are two better, undersung, programs:

to be honest, I don’t know how those two (or any AV) react positively/negatively with Wayland. It would be interesting if it was a trend but I haven’t read a thing.
food fer thought, and good luck

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.