Citrix Workspace

Good Morning.

New User, New to Linux (well, I did try it several years ago, but it was unusable for my needs (work), so it didn’t last long).

I would really appreciate if someone can walk me through installing Citrix Workspace. This is a must for me as it is required for work. I tried installing it yesterday, going through the steps as documented on Citrix’s website, but it didn’t work. I even tried installing Ubuntu, and it still didn’t work.

Thank you.

Not a Citrix user here but I found the following article in the ArchWiki you might want to have a look at:

https://wiki.archlinux.org/title/Citrix

Welcome to the community @powerincarnate and good luck!

1 Like

Welcome to the forum @powerincarnate :enos: :enos_flag: :partying_face:

thank you for the wonderful welcome.

I tried the archwiki all of yesterday (and this morning for other installs). It is likely I’m doing something wrong regarding citrix as a new user.

1 Like

Sadly, I had to revert back to Ubuntu and seek some answers there.

Ultimately the issue is with Citrix, who haven’t updated their Citrix software dependencies, which requires this dependency ‘libidn11’, but ubuntu, and probably endevouros ships with libidn12 causing the error. There were multiple efforts on various forums trying to get a workaround, but ultimately this worked.

It did work, I was able to log into both of the workspaces that is required for my job.

It will be Ubuntu for now, but I do like the EndevourOS project and wish it the best.

There is actually only libidn11 in the Arch repos and not libidn12:

community/libidn11 1.33-2
    Implementation of the Stringprep, Punycode and IDNA specifications

So there might have been some other issues at play here for you not getting it to work on EnOS.

What went wrong when you tried it on EnOS? Any specific error message?

Looking at the AUR page for icaclient there is some issue mentioned in the latest comments. Was yours as well the same? If so, perhaps you could keep an eye on the said page to see if some solution to it will eventually be found.