Cisco anyconnect vpn

i need to isntall anyconnect to be able to connect to gitlab for my work but when i did, i keep getting this error

you are missing the required library for authentification method you requested

anyone encountered this issue? any ideas how to solve it? i found a tip to install sudo pacman -S webkit2gtk but it did not work.

any help appreciated

Try installing openconnect.

$ pacman -Si openconnect

Repository      : extra
Name            : openconnect
Version         : 1:9.12-1
Description     : Open client for Cisco AnyConnect VPN
Architecture    : x86_64
URL             :
Licenses        : LGPL2.1
Groups          : None
Provides        :
Depends On      : libxml2  gnutls  libproxy  vpnc  krb5  lz4  pcsclite  stoken  tpm2-tss  oath-toolkit  libproxy
                  libp11-kit  xdg-utils
Optional Deps   : python: tncc-wrapper
Conflicts With  : None
Replaces        : None
Download Size   : 866.81 KiB
Installed Size  : 3899.11 KiB
Packager        : Antonio Rojas <>
Build Date      : Fri May 26 00:44:17 2023
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Perhaps you will need networkmanager-openconnect too.

More info:

openconnect i have also… this is what i try…


confusing… :roll_eyes:

Please refer to the wiki article I posted above.

According to it, you would need to use sudo ...

mmm… no… there is something with the SSO single sign-on (SSO) as described in the doc, but i dont really know what I am doing wrong…

it should somehow open a web browser and allow to authenticate… but it just does not happen :frowning:

There is this [SOLVED] thread on Arch’s forum about the same issue.

There is a suggestion at the end of the thread to install one or another package from AUR to make this work.


well… i have installed this git package no progress… it still doesnt even pop up the web window where i could insert my credentials, which is something the guy in the threat at least managed to have by default…

I mean - is there something extra i need to do after installing it? some configuration or whatever? connection to firefox browser? Still this annoying error with sso and i am completely stuck …


hmm… so the workaround with python venv described in the thread works but it is very very very unwieldy.
basically i need to activate venv everytime + run a command to open sso window, then put the credentials, confirm two factor on mobile add sudo password and yes… i am connected.


to make it even worse, when i disconnect from the vpn, basically all my connections stop working so i need to reload/restart then (either wifi of cable).

this is obviously pretty bad and extremely anoying and if i dont find a better solution, i will probably be forced to switch to an OS where this vpn crap just works, since i have to use it all the time… :frowning:

i hate cisco so much, its overengineered garbage… you should install windows in a virtual machine, then you can copy the files with ssh or something

i solved it by installing sudo pacman -S webkit2gtk

1 Like

You should be able to use openconnect, without the Cisco client, to connect.

sudo openconnect --protocol=anyconnect -u user --servercert pin-sha256:thisPin -s ‘vpn-slice’

The pin should be revealed, when you try to connect the first time. The password for the server will be ask during connection.