Cinnamon stuck with default theme

After updating eos-settings-cinnamon and rebooting, I find my system takes forever to sign in, and after it does, Cinnamon is stuck with the Arc-Darker theme and Adwaita icons, with attempts to change this in the Theme settings being overridden somehow. I can only change the cursor. These issues persist even after uninstalling eos-settings-cinnamon. Here’s what happens running “cinnamon-settings themes” from the terminal:

[@-desktop ~]$ cinnamon-settings themes cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/cinnamon-control-center-1/panels/
/usr/share/cinnamon/cinnamon-settings/ DeprecationWarning: Gtk.Window.set_wmclass is deprecated
self.window.set_wmclass(wm_class, wm_class)
Loading Themes module
/home/****/.themes/ does not exist! Skipping

I’m using Cinnamon too and I’ve got same deprecation warning about Gtk.Window.set_wmclass, but it opens the app without issues.

Maybe you can try to install libgoa:

sudo pacman -S libgoa

libgoa is only for managing online accounts. it has nothing to do with theming.

I found something potentially useful in journalctl. The cinnamon xsettings daemon (csd-xsettings) is segfaulting on launch: stack trace from journalctl

I also managed to build csd-xsettings locally and try running it in gdb. Here’s what happened:

Thread 1 "csd-xsettings" received signal SIGSEGV, Segmentation fault.
0x00007ffff7516f25 in g_settings_schema_has_key (schema=0x0, key=0x55555556339f "high-contrast") at ../glib/gio/gsettingsschema.c:1063
1063      return gvdb_table_has_value (schema->table, key);    

And here’s a backtrace from gdb: backtrace

I ended up giving up and reinstalling from scratch.

We’ll see if anything goes wrong this time…

cinnamon just was upgraded in version… could be related… instea dof a compplete reinstall you should have tried removing configs from cinnamon in your users home…

1 Like

Well, csd-xsettings started segfaulting again on the new install after updating to Cinnamon 5.8.1 and rebooting.

And there is nothing in ~/.config that should cause that.

I should also note that I tried resetting Cinnamon to default settings, and it didn’t stop csd-xsettings from segfaulting.

EDIT: I just found these lines in journalctl - this might be the cause of the segfaults, but I don’t know where to go from here:

Jun 09 14:47:48 ****-desktop dbus-daemon[9445]: [session uid=1000 pid=9443] Activating service name='org.gtk.vfs.Daemon' requested by ':1.0' (uid=1000 pid=9441 comm="csd-xsettings")
Jun 09 14:47:48 ****-desktop dbus-daemon[9445]: [session uid=1000 pid=9443] Successfully activated service 'org.gtk.vfs.Daemon'
Jun 09 14:47:48 ****-desktop org.gtk.vfs.Daemon[9458]: fusermount3: failed to access mountpoint /run/user/1000/gvfs: Permission denied

Turns out those were not relevant - that was a completely different issue caused by xdg-desktop-portal-gnome being installed. Removing it fixed those errors, but I still can’t get csd-xsettings to do anything other than fail.

This turned out to be an actual bug in csd-xsettings itself, and has been fixed in master.