Chromium reporting being out of date

In the middle of browsing today, reCAPTCHAs started reporting that I needed to upgrade to a compatible browser, and then when I went to use Messages for web it said that my browser was out of date, which it is not. I installed Google Chrome from the AUR, and am not encountering that problem with Chrome. They both report being Version 86.0.4240.75. Anyone have any ideas? I haven’t been able to find anyone else having the same problem.

Who uses reCaptcha? I thought that is only for commercial websites.

1 Like

A fair number of websites require it when making an account and often when logging in.

I think someone (some advertiser on the web site you were on) was trying to scam you into installing malware; they probably have a button to click to “install the latest version.”

Granted, it probably wouldn’t have succeeded, coz Linux, but they don’t exactly use quality filtering when they give those “warnings.”

3 Likes

It’s across multiple sites. Screenshot_2020-10-19_19-27-6

Have you tried Chromium or Chrome from something like the Chaotic AUR?

For what it’s worth, I have just now visited multiple sites that use recaptchas, using the same version of Chromium as yours, installed straight from the Arch repos, and all are working correctly.

I have flash disabled already, and on a hunch I tried disabling javascript to see if that would prompt the type of messages you’re seeing; it didn’t. I still got the recaptcha challenges, I simply couldn’t submit them as the button wasn’t working without javascript.

I don’t know what’s happening with your Chromium, but so far I haven’t been able to reproduce the behavior.

3 Likes

Thanks for your efforts. I’ve tried disabling all of my extensions just to make sure, and I did check to see that javascript was enabled. I didn’t make any changes this afternoon when the issue started, so I have no idea what caused this behavior.

1 Like

If you visit this recaptcha test page (it’s safe), do you still get the out-of-date message?

1 Like

Yes

The only thing I’ve been able to dig up is a report on the Vivaldi forum where a couple of users were experiencing this in the last day; both users were able to identify the issue as coming from the use of an extension called Trace.

If you have the Trace extension installed, you may want to try uninstalling it and restarting the browser. I know you have disabled all extensions already, but in the past I have had a wonky extension that required removal to stop its odd behavior - disabling it wasn’t enough.

That extension apparently does something to the User Agent that makes it appear to be an out-of-date browser. If you aren’t using Trace, but you are using an extension that allows changing or switching of the User Agent, you may want to investigate that extension.

4 Likes

Thank you! That helped me narrow it down. I am cautiously optimistic that I’ve found the issue.

I had DuckDuckGo’s privacy extension installed, which I removed, but it wasn’t until I cleared the chromium cache that the issue was resolved. I don’t understand why that same extension works when installed to Chrome. :man_shrugging:

1 Like

I have no idea why it would work on Chrome and not Chromium (you’d think a DuckDuckGo privacy extension would be more extensively tested on Chromium that Chrome :grin:), but hopefully this solves your issue.

You can always revisit the extension after either it or Chromium gets an update.

2 Likes

I’ll definitely keep an eye out. I’m quite curious about where the problem occurred, and if anyone else encounters it.

Thank you so much for your help. I really appreciate it; I was so frustrated!

1 Like

Okay I get that. But I honestly hardly ever see it here. Few sites I’ve been on but not many. But I guess I’m not signing up to much?

1 Like