Chromium/Electron based applications' windows do not open on Native Wayland

Trying to get Vivaldi, Vesktop, Spotify, VSCodium working natively on Wayland for a couple of reasons that I can’t avoid: -

  1. Video playback being stuttery and weirdly paced on start and resume
  2. Text in certain regional languages do not display if they contain a certain character (the letter வா in Tamil) for which I’ve tried reinstalling the respective fonts to no avail
  3. XWayland taking up a RIDICULOUS (40%!!!) amount of gpu usage

I can safely attribute these issues being the fault of the applications in question running on X11 instead of native Wayland as these issues do not happen on Firefox (which runs natively on Wayland). I can’t switch to firefox for all of these applications as there are certain features that I use on a daily basis that are just missing.

As for the problem itself, these applications, when launched with the command line flags `–enable-features=UseOzonePlatform --ozone-platform=wayland" or any variation of it causes the application to not connect to Wayland, and does not even open a window for it. The application does open up, as the task manager acknowledges it. Opening chromium/electron based applications via Wayland worked just fine on my previous installations of Nobara/Fedora, but only do not work in EOS. Can anyone help me at least get the window to display?

Correction, the tamil font thing (reason number 2) is not an XWayland problem as I tested it out on a friend’s machine (also running EOS) booting in on Wayland. The issue was present on both X11 and Wayland modes.

I have no issues with an AMD apu, I don’t use any flags.
Consider giving some details about your setup

did you try --ozone-platform-hint=auto that’s what i’ve been using to launch electron natively.

But for chromium it doesn’t owrk, only --ozone-platform=wayland works for that one, however i remember it required some chromium flag configuration.

Make sure it’s at least configured like this internally:

As rabcor said, --ozone-platform-hint=auto works for me. For hardware acceleration, also use --enable-features=VaapiVideoDecodeLinuxGL. Both works for both Chromium- and Electron-based apps (in my case, Chromium, Slack, Webcord).

Alternatively, for Electron -based apps, you can use ELECTRON_OZONE_PLATFORM_HINT=auto as environment flag f.ex using Flatseal. For HW accel you still need to pass --enable-features as a command.

--ozone-platform-hint=auto and setting the flags via the browser itself produce the same result, the latter thus causing me to lock myself out of the application.

I’m running an Intel iGPU (13th Gen i9-13900H) on the display on wayland with the currently active kernel module being i915. eos-sendlog for some reason doesn’t work properly so I’m not able to just sent the journalctl output.

The issue persists even on Firefox. Here’s my system info:

The issue persists even when I’m running my display on my NVIDIA GPU as well. I’ve also tried combining both GPUs with X11 and Wayland to see if this issue disappears but to no avail. Here’s my system info when connected to the NVIDIA GPU on X11:

Here’s a list of all the packages I have installed for reference:

did you try runnning from terminal? does it give you any specific errors?

Also are you sure your drivers (mesa, vulkan dependencies and such) are installed?

  1. no, it doesn’t
  2. yes pretty sure (as you can see from my installed packages list). I’ve come here after scouring all of the relevant arch wiki pages to find a fix.

What makes this weirder is that somehow the problem does not present itself when I’m screen recording on obs. Noticed this when I tried to get a recording of the problem. Thus, I have attached a recording of the problem from my phone.

Notice the audio/video desync at the start and the sudden speedups that happen to gradually correct it.

MPV with the --hwdec=vaapi flag works flawlessly on my current config, indicating no problems with VAAPI and my GPU.

About the fonts problem, installing other fonts for the same language worked so it’s no longer an issue.