Chromium crashes after update

Chromium and Opera crash in lxqt about 2 seconds after starting the browser.
I checked this behavior in my EOS-Plasma installation where the latest linux-kernel was installed today.
No problems, chromium doesn’t crash.

I tried to solve the problem by
a) installation of lts-kernel
b) remove and re-install chromium
c) installing chromium-dev (was denied, a lot of error-messages)
d) deleting the chromium profile
Nothing helped.

Now I omit lxqt because chromium is my standard browser. I don’t like Firefox.
Firefox doesn’t crash in lxqt.

Start it from a terminal and see if there are any meaningful errors.

[3125:3125:1223/] Failed to export buffer to dma_buf: Datei oder Verzeichnis nicht gefunden (2)
[3125:3125:1223/] Failed to export buffer to dma_buf: Datei oder Verzeichnis nicht gefunden (2)
[3125:3125:1223/] Failed to export buffer to dma_buf: Datei oder Verzeichnis nicht gefunden (2)
[3125:3125:1223/] Failed to export buffer to dma_buf: Datei oder Verzeichnis nicht gefunden (2)
Speicherzugriffsfehler (Speicherabzug geschrieben)

Are you using a compositor ?. Does it crash if compositor is disabled?

I don’t know what a compositor is.
How can I find out in lxqt ?

I remember a “compositor” in KDE settings, but cannot find one in lxqt.

ps aux | grep picom
ps aux | grep picom
franz       6894  0.0  0.0   6932  2436 pts/0    S+   14:23   0:00 grep picom

So no compositor. Try installing picom and see if running it, then the browser helps.

I installed picom, but nothing changed. Rebooted lxqt, but still the same error.
I think I’ll give up.
Thank you for helping me, @xircon

mbich, was soll sich durch die bloße Installation ändern…

When running a command in a terminal to get error output, you should switch to English beforehand:


This is only valid for this terminal. (…or better drive in English anyway.)

You can search for such issues.

He already has problems w/o a compositor (whereas there are others, e.g. compton, we also do not know if openbox or xfwm4 or another window manager is underneath). If he runs one now, what should improve?

Lately chromiumnis bit buggy can be fandom when i click to much on somepoint chromium shutoff

many times something changes when a package is installed. Example: language-packages for nemo or firefox etc.

The search for a solution did not help. All the “solutions” people found in fedora, manjaro etc. I tried, but still chromium crashes and Opera too.

I installed LXQT with the newest iso from Endeavour and it installed Openbox.
Installed LXQt yesterday again because I wasn´t able to add my other linux-distros to systemd-boot.
It is too complicated for me.

So I deleted the 1GB EFI partition for the systemd-boot partition and installed LXQt with Uefi-boot.
That’s what I can do and it works.

After the new installation of LXQt I used chromium for about 12 hours without problems.
This morning there were updates.
After the updates chromium is crashing.
And Opera is crashing.
No solution in sight for me.
In some articles from searching this problem, they said that chromium was the problem and new versions fixed the crashes. They couldn’t find a solution until an update with a new version appeared.

Language-packages are loaded by their respective programs.
A program to be executed like the mentioned compositor (a compton fork) must be started explitzit (with options).

Especially when you already know there are problems, you have to look at which packages should be updated. You should note them down, install them one by one or in related groups if necessary. This way you can find problematic packages.

There is currently no such general problem with Chromium (or Chromium-based browsers). This would otherwise occur on other systems as well.

I run EndeavourOS with testing and testing-community generally enabled, LXQt, Openbox, nouveau and on another machine (originally Antergos) with intel.

The current Chromium version is 108.0.5359.124-1 from 2022-12-14. This works w/o any problems.

inxi -GM


Start Chromium as described here (as a test): - Falkon, Chromium: Freezes, Glitches

1 Like

I did not know there would be problems with chromium. It happened after the update.

It happened to others too, but not to all.
On my PC, it only happened in Endeavour LXQt, not in EOS-Plasma.
Since nobody had a solution for it, I deleted LXQt and installed EOS-Xfce.
It doesn’t happen in Xfce.

The “solution” for chromium crashes on EOS-LXQt for me was the removal of EOS-LXQt.

[franz@eos-xfce ~]$ inxi -GM
  Type: Desktop System: Wortmann_AG product: TERRA_PC v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: H61M-S2PV serial: <superuser required>
    UEFI: American Megatrends v: FH WG date: 04/24/2013
  Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730] driver: radeon v: kernel
  Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: radeon
    unloaded: modesetting dri: r600 gpu: radeon resolution: 1920x1200~60Hz
  API: OpenGL v: 4.5 Mesa 22.3.1 renderer: AMD REDWOOD (DRM 2.50.0 /
    6.1.1-arch1-1 LLVM 14.0.6)
[franz@eos-xfce ~]$ 

@axt , danke für Deine Hilfe. Deine Webseite finde ich sehr gut.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.