Chromium browsers not starting

Hi all. I have done a fresh Gemini install on an MS Surface Pro 6 with a Gnome desktop. I then added the Surface kernel from here: to enable touchscreen support. All working fine, including wifi & touchscreen.

Firefox opens with no problems but I need to have MS Edge or another chromium browser for occasional work use. Unfortunately, none of Edge Stable, Edge Dev or Chromium will open. When run from the GUI I get an hourglass for a while, then nothing. I ran Chromium from the commandline with debugging on:

stu@surface ~]$ chromium --enable-logging=stderr
[19301:19301:0611/] This is Chrome version 125.0.6422.141 (not a warning)
[19301:19301:0611/] Skipping mandatory platform policies because no policy file was found at: /etc/chromium/policies/managed
[19301:19301:0611/] Skipping recommended platform policies because no policy file was found at: /etc/chromium/policies/recommended
[19338:19338:0611/] InitializeSandbox() called with multiple threads in process gpu-process.
[19340:19340:0611/] ChildThreadImpl::EnsureConnected()

This just seems to then hang until the process is killed.

Some system info from fastfetch:

OS: EndeavourOS rolling x86_64
Host: Surface Pro 6 (124000000000000000000000D:0B:13F:5C:10P:38S:01E:0)
Kernel: Linux 6.9.3-arch1-2-surface
Uptime: 1 hour, 32 mins
Packages: 897 (pacman)
Shell: bash 5.2.26
Display (LGD0555): 2736x1824 @ 60Hz (as 1368x912) [Built-in]
DE: GNOME 46.2
WM: Mutter (Wayland)
WM Theme: Adwaita
Theme: Adwaita [GTK2/3/4]
Icons: Qogir [GTK2/3/4]
Font: Cantarell (11pt) [GTK2/3/4]
Cursor: Qogir (24px)
Terminal: GNOME Console 46.0
Terminal Font: Source Code Pro (10pt)
CPU: Intel(R) Core™ i5-8350U (8) @ 3.60 GHz
GPU: Intel UHD Graphics 620 @ 1.10 GHz [Integrated]
Memory: 1.79 GiB / 7.68 GiB (23%)
Swap: 0 B / 8.80 GiB (0%)
Disk (/): 8.86 GiB / 224.02 GiB (4%) - ext4
Local IP (mlan0): *
Battery: 100% [AC Connected]
Locale: en_GB.UTF-8

Any idea what is going on? Thank you!

Have you tried another Chromium browser like Brave? I never used MS Edge nor will I.

Same story with Brave so I assume this is something about the Chromium engine. Maybe versus Wayland?

1 Like

try adding this to your chrome command to startup and see if you get the errors.

No, same thing. It just hangs on that last ChildThreadImpl::EnsureConnected()

UPDATE: I just restarted with the default (non-Surface) kernel and now I can open Edge, Brave, etc.

So I guess this is something I need to take up with the Linux Surface devs.

Thanks for your help anyway @thefrog

1 Like