Chrome not playing Youtube videos, Audio not playing

Lately Ive been struggling to get my computer to produce any audio. And now on top of the inability to do so, I cannot even watch youtube videos. I pause and unpause just for it to stay still as if it were paused. Manjaro linux worked perfectly for me until recently, but I couldn’t install it because my touchpad, bluetooth, and wifi were not working, so I went with endeavour OS. This is now seeming to be a mistake.

I assume you ask for help, and not just venting your frustration from switching from one non working system to the other.

You could start by providing more info:
What computer do you have? Output of command inxi -F

Can you play videos on other websites? Can you play audio / video using mp3 player / video player? How did you install Endeavour?

This is like a basic stuff which will help other members of community to assist you.

Can you share the output of inxi -xxA? From the looks of it, it’s likely that your sound server (either pipewire or pulseaudio) isn’t working properly. But you should also test things out on another browser just to be sure that the problem isn’t with your browser.

1 Like

It might also help if you type this into a terminal to see what pipewire services are or are not running:

ps axu | grep 'pipe\|wire'

Output of inxi -F:

  Host: spade Kernel: 5.15.86-1-lts arch: x86_64 bits: 64 Desktop: KDE Plasma
    v: 5.26.4 Distro: EndeavourOS
  Type: Laptop System: HP product: HP ENVY Laptop 17m-ch1xxx
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 8984 v: 62.46 serial: <superuser required> UEFI: Insyde
    v: F.10 date: 07/19/2022
  ID-1: BAT0 charge: 12.3 Wh (24.8%) condition: 49.5/49.5 Wh (100.0%)
  Info: quad core model: 11th Gen Intel Core i7-1195G7 bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 749 min/max: 400/4800:5000 cores: 1: 868 2: 763 3: 704
    4: 797 5: 615 6: 730 7: 718 8: 799
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: intel
    unloaded: modesetting dri: i965 gpu: i915 resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel Xe Graphics (TGL GT2)
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-tgl
  Sound API: ALSA v: k5.15.86-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi
  IF: wlan0 state: up mac: 0c:9a:3c:3d:a4:c3
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
  Local Storage: total: 504.19 GiB used: 16.68 GiB (3.3%)
  ID-1: /dev/nvme0n1 vendor: Intel model: HBRPEKNL0202AH size: 476.94 GiB
  ID-2: /dev/nvme1n1 vendor: Intel model: HBRPEKNL0202AHO size: 27.25 GiB
  ID-1: / size: 212.11 GiB used: 16.32 GiB (7.7%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-2: /home size: 212.11 GiB used: 16.32 GiB (7.7%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-3: /var/log size: 212.11 GiB used: 16.32 GiB (7.7%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-1: swap-1 type: partition size: 24 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p6
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 288 Uptime: 13m Memory: 11.46 GiB used: 4.6 GiB (40.1%)
  Shell: Bash inxi: 3.3.24

I tried audio and that didnt work either.
I tried using brave browser rather than chrome, and that had no effect.

output is:

itsrxmmy     973  0.0  0.1  44424 12536 ?        S<sl 19:40   0:00 /usr/bin/pipewire
itsrxmmy     974  0.0  0.1 342216 23412 ?        S<sl 19:40   0:00 /usr/bin/wireplumber
itsrxmmy    6913  0.0  0.0   6564  2532 pts/2    S+   19:55   0:00 grep pipe\|wire
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8
  Sound API: ALSA v: k5.15.86-1-lts running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: yes

I tried brave browser rather than chrome and that didnt work

You have two sound servers running at the same time.

Disable one of them and test your audio again.

sudo systemctl disable pulseaudio
Failed to disable unit: Unit file pulseaudio.service does not exist.
Failed to disable unit: Unit file pipewire.service does not exist.

cant even disable either of them

Try it with the --user flag

systemctl --user disable pulseaudio

Failed to connect to bus: No medium found

Check systemctl --user status pulseaudio?

Also you can check:

systemctl --user status pipewire-pulse.service 

But my friend, you are on Kernel 5.15. Quick Googling shows similar issues with Intel TigerLake and 5.x Kernel series. Support was being added, but some issues were solved as far as in 6.0.5

Because your processor is quite new and if you will not be able to fix it with software changes, your best bet would be just to install latest Endevour with latest kernel, and then exclude kernel package from upgrading, if you want to sleep more calm :wink:

If it were me i wouldn’t be using Chrome. :man_shrugging:

how do i install new kernel

Unit pipewire-pulse.service could not be found.

its the same for brave browser and firefox

To get new Kernal, you need to upgrade your system:

pacman -Syu

i literally run this command every day and it never fixed it…

I have the same hardware on one of my machines

I would recommend you to try issuing this command to reinstall kernel, firmware and pipewire stuff first. There are issues with wireplumber so I also recommend pipewire-media-session

yay -S linux linux-headers sof-firmware pipewire pipewire-pulse pipewire-media-session

Then reboot and make sure you are booting in the correct kernel (current version of arch kernel is 6.1.8.arch1-1)

Then run alsamixer press F6 and select the first sof card from the list. Now make sure the auto-mute mode is disabled

Also make sure you are not running two sound servers at the same time, and that you have rtkit and/or realtime-privileges packages installed so pipewire can work with realtime priority.