Changing the resolution of fullscreen apps?

Wdisplays only appears to pick up my native resolution, and so do full screen apps, only allowing me to use 1080p native which can be rather laggy on certain applications

swaymsg -t get_outputs should list all available resolutions of your displays. Not sure if you can go to other display modes not listed. As for changing the resolution of individual applications, this will heavily depend on the application itself, so more details are needed here…

It only lists native resolution

LXDE and LXQT detected other resolutions fine

  Available modes:
    1920x1080 @ 59.934 Hz
    1920x1080 @ 47.999 Hz

You should be able to set the resolution of your display to other resolutions as listed by LXDE in your sway config (see or the official documentation). But again this is probably not the solution you’re looking for. I’m not aware of a way of generally changing the fullscreen resolution on a per app basis. This may only be possible for specific apps if the app itself supports it.

The issue is that it is not actually picking up the list of resolutions my display is capable off, only native

Meaning that apps when grabbing the list of resolutions it can change to only picks up native

Unless you provide me with more information about which applications exactly are causing trouble, I won’t be able to help. As I’ve said, you won’t be able to set a per application resolution. You should always be able to set sway to any of the listed resolutions (e.g. as listed by LXDE).
Also some system information would be nice.

But since I suspect that you’re running a NVIDIA card, a word of warning: There is possibly no solution to your problem as sway does not support NVIDIA cards.

It is the Celeron J3160;s iGPU, the issue is that the listed resolutions on Sway are only native

[nochill@nochill-laptop ~]$ swaymsg -t get_outputs
Output eDP-1 'Najing CEC Panda FPD Technology CO. ltd LC133LF2L03 Unknown' (focused)
  Current mode: 1920x1080 @ 59.934 Hz
  Position: 0,0
  Scale factor: 1.000000
  Scale filter: nearest
  Subpixel hinting: unknown
  Transform: normal
  Workspace: 2
  Max render time: off
  Adaptive sync: disabled
  Available modes:
    1920x1080 @ 59.934 Hz
    1920x1080 @ 47.999 Hz

After a bit of googling, this seems to be a known issue with wlc/ sway. In short, sway picks up the resolution of you tty. (Don’t know if this would be an issue if starting from a display manager, but since you did not provide this information, I can’t help you there).

You might want to read through the relevant issue or check this wiki article: