Changing filename on curftpfs mount fails

Hi all, I’m new to endeavouros, though I’m not new to Linux at all :slight_smile:

I want to create a sync/backup folder on a hard drive that is connected to my router. I have FTP access to the drive, and I have unison setup to sync the files. The problem is that unison fails because I cannot change the names of the files on the hard drive.

The relevant line in my fstab file reads:

curlftpfs#file_server:dont_show_me@ /mnt/router fuse rw,auto,user,uid=1000,gid=1000,allow_other,utf8,_netdev 0 0

For what it worth, after each attempt I did to change this line (adding/removing umask=002, adding/remove ‘ipv4’) I didn’t restart the machine. Only umounted and then mounted the drive using sudo mount -a.

I would appreciate any help, either with an alternative solution or with fixing mounting the device.


Welcome to the forum! :smile:

That fstab entry looks strange, as it has a comment mark # near the beginning of the line.

I guess the router disk cannot be mounted using samba or NFS?

EDIT: does this help:
And this:

Hi, thanks for the reply.

The arch wiki was my starting point, but since I cannot change the name of the file even if I mount as the same user as the one that I used to mount the file system, I am stuck there. Using NFS is an option, but I’m not sure how to sync my machine’s clock with the router’s one. I do have a workaround though. I have a raspberry pi that is serving as a minecraft server for my kids and as a web server for me to play around with flask. I can actually connect the drive directly to it and mount it via sshfs.

This raises a new question. How do I make sure that the network based file systems are mounted only after wifi connection is established?

Sorry for the delay, I was out of town.

You could put your mounting script into autostart (which DE are you using?). You may check the connection e.g. with ping, something like:

while true ; do
    ping -c 1 >& /dev/null && break
    sleep 1s
# mount here!

As I said I ended up connecting the drive to my raspberry pi and I mount it now with sshfs. I used gnome extension (guess you know which DE I’m using) called executer to execute a python script that verifies that I’m connected and that the drive is not mounted and then mount the drive using sshfs.

Thanks for the help.

1 Like