Change sddm background picture

I use EndeavourOS with KDE Plasma as my desktop.
How can I change the background of SDDM? And I mean the one that shows before I log in to my account (eg after booting or logging out). I know how to change the lock screen that shows after logging in.

system settings->startup and shutdown->login screen(SDDM).

The click on the image in the thumbnail.
image

1 Like

Yes, that’s what I did at first, but it only changes the background picture after signing in.

When I boot up the computer and enter the SDDM to sign in, the image is different (it’s an EndeavourOS default wallpaper. It is nice don’t get me wrong, but I want to use soething else.)

No. That is in a different place inside system settings. The path I gave you is specific for sddm and the initial login screen.

Make sure you follow it:
system settings->startup and shutdown->login screen(SDDM)

2 Likes

this is what im talking about.

Yes. We are talking about the same thing.

The first screen(login) in your video is exactly where I noted above:
system settings->startup and shutdown->login screen(SDDM)

The second screen(lock) is here:
system settings->workspace behavior->Screen locking

They are both in system settings but in different places

1 Like

but on both options i have set the same picture. like so:

Do not confuse the Plasma lock screen with SDDM (the login screen). They may look similar, but they are not the same thing, and their settings are not shared.

Look in the sddm config file and see what is in it.

alright folks i figured it out. in /usr/share/sddm/themes/breeze there is a file called theme.conf.user that had this text:

[General]
background=/usr/share/endeavouros/backgrounds/endeavouros-wallpaper.png
type=image

so i had to edit the ‘background=’ bit to add the path to the picture i actually wanted .
curiously there is another file, theme.conf that read:

[General]
showlogo=hidden
logo=/usr/share/sddm/themes/breeze/default-logo.svg
type=image
color=#1d99f3
fontSize=10
background=/usr/share/wallpapers/Next/contents/images/5120x2880.jpg
needsFullUserModel=false

i did not edit that one.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.