Change Screen Shortcut Not Working

When I press meta+P and select a screen, nothing happens. And it’s also missing the corresponding icons. I don’t know where to find more details, any help is welcome.

I found that the theme was responsible for making the icons disappear, but it still doesn’t work when I select a screen mode.

@SrDlay ,
Correct me if I’m wrong. These should happen. The selection (from left)
1 – switch to TV
2 – swith to ‘laptop’
3 – duplicate
4 – cursor crosses left margin it arrives to the TV
5 – crossing right margin means a smooth arrival to the TV

That’s correct. By default it is intersecting with the right edge, I can only switch between modes by manually turning off the monitor I don’t want to use. When I select one of the options using Meta+P nothing happens.

AFAIK instead of arandr we can use kscreen-doctor command. So I inserted into some parts of
kscreen-doctor -o
(BTW this shows what resolutions are possible)

#xrandr --output eDP-1 --primary --mode 1920x1080 --pos 0x0 --rotate normal --output HDMI-A-1 --mode 1600x900 --pos 1920x0 --rotate normal
kscreen-doctor output.HDMI-A-1.enable \
               output.HDMI-A-1.mode.0 \
               output.HDMI-A-1.position.0,0 \
               output.eDP-1.enable \
               output.eDP-1.mode.4 \

Prepare some variants (disable instead of enable if you want either of them to switch off)
I put this script into Autostart.
Right-click on your desktop and select “Display settings” from the popup menu.
also helps you to modify monitor settings (Primary, Enable etc)

1 Like

Okay, this doesn’t solve the problem that the native way to quickly switch between system views still doesn’t work, but the script is useful, so thanks anyway. I don’t know what caused the problem, but it will probably come back with a clean install.