Change i3 default terminal

Hello,

I have tried to change the terminal used both in the i3 config as well as in the eos-script. However, I have not been able to make it change. I am trying to change it to tmux.

Thanks,

Frog

so what exactly have you done to change the default terminal?


# start a terminal
bindsym $mod+Return exec xfce4-terminal


assign [class="Xfce4-terminal"] $ws1


for_window [class=Xfce4-terminal] focus

is set in i3 config, only needs to be changed to your terminal executable.

i3 or sway is about as basic and fool-proof at changing configuration (like this) as anything in the world. The text config file simply needs to be edited with a valid executable installed and in your path (or an absolute path of course)…the config reloaded and voila, magic happens!

1 Like
# start a terminal (tmux)
bindsym $mod+Return exec xfce4-terminal -e tmux

Why not just:
bindsym $mod+Return exec tmux

so true… tmux is not a terminal emulator… it is a multiplexer… :rofl: :penguin: :man_shrugging:

So you can not run it instead of a terminal emulator… only inside one

I guess it is my bad then. Do I change it everywhere for xfce-terminal -e tmux?

try it… some tip for such task:
use xed editor and replace option:
replace

Now now…someone running a tiling manage should use vi or maybe nano (hee hee, old fashioned am I).

yes i do use i3 but the reason is that I can simply choose what ever I want and integrate it into my setup as I like… and I do like GUI editors, in the same as some cli tools p.e. i do love nano but vi? no way :hugs: :milky_way:
In addition for this case you should create a patch :wink: