Cassini won't install on Pinebook Pro


I’ve installed Cassini on my desktop and liked it so much I decided to install in on my Pinebook Pro.

Followed the directions here:
and it doesn’t install from the SC card to the eMMC. I used the Endeavour USB boot disk from my PC and ran the ARM installer since my Pinebook Pro only boots from eMMC or SD card.

I tried one time to install LXDE and it installed to the SD card instead of the eMMC. When I re-ran the installation to try to install it to the eMMC all the text was white against a white background so I couldn’t accomplish the installation.

My second attempt after recreating the SD card was to try to install LXQt. All it does is stick at the Set up screen at 0% with initialize pacman...copy pacman mirrorlist and keyring to target... under the progress bar.

I guess my only other option is to purchase an eMMC to USB adapter? Any other ideas?

Hi! It’s been a while since I’ve done an installation in my pinebook pro, the mmc install has worked great for almost two years now, so I could only try to replicate this with an SD card, but what I understand is that you can install to an SD card just fine, is this right?

About the emmc install, my notes tell me that emmc is always /dev/mmcblk2, is this what you are pointing to?

Hi. I can install just fine to the SD card. When I boot from the SD card the installer installs my OS choices to the SD card. In my experience with Manjaro this was the normal process. But when I reboot to run the installer and attempt to install it to the eMMC, the SD either doesn’t boot, or if it does boot I can’t read the install text because it’s white text on a white background and I can’t see enough to choose the eMMC as an install location.

After reading some other posts I’ve ordered an eMMC USB adapter which should take care of the issue.

1 Like