Cassini installation bootloader choice issue

The issue you are seeing is described in the Arch wiki. It is an issue with xf86-video-intel and 12th gen intel CPUs.

So the boot loader selection error is caused by the elements on the ui, its not passing the value and thou causing the TypError.
I did managed to install on another machine, and all went fine.

Now able to get back to this and yes, this does seem to resolve the frozen display when attempting some click actions in certain windows. At least in my quick testing the modesetting driver appears to not have the same issues.

I was never having any noticeable screen flickering. I did try this parameter before removing the intel drivers but I didn’t notice any change.

Intel is working on a totally new driver for Linux for the Iris Xe that doesn’t have anything for the older gen hardware mixed according to this article? Also the new Arc cards will be opensource kernel module.


Thank you - totally forgot about this. A few years back I had to do this on a different distro as well to stabilize intel operation.

To summarize, on a Dell XPS 12th gen laptop, once getting through the install and removing xf86-video-intel upon first boot, things are subsequently stable here. ty

You can unselect that package during the installation


Have the same issue with Intel Alder :smiling_face_with_tear: I can’t install endeavour it gets stuck on the bootloader.

Before starting the installer, uninstall xf86-video-intel and restart X11.(Don’t reboot)

Hi. I have the same issue. When it reaches the boot-loader section, it behaves strange (freezes, problems happen with rendering, and I can not select/deselect any option). Then when after lots of waiting the next page loads (and then the next page, then the next page) in the final page, when it asks for confirmation to install the OS (with summary of all of my entered options), when I confirm, it jumps back to the boot loader page, this time stuck forever and after a few minutes threw this error:

I cannot apply any of the options mentioned above. I don’t know how to remove xf86-video-intel. I don’t know how to set i915.enable_psr=0

This is the result of inxi -Faz:

Welcome to the forum!

If you have a 12th gen or later Intel CPU that is expected with the current ISO. It should be addressed once the next ISO is released.

In the meantime, you can remove it with sudo pacman -R xf86-video-intel and then restart X11(Don’t reboot)

1 Like

Thank you very much @dalto
I confirm doing sudo pacman -R xf86-video-intel and then sudo systemctl restart lightdm.service fixed the issue and right now it is being installed



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.