Capture card not detected

I have a blackmagic intensity pro 4K, I got it working and been using it for months.
To make it work I installed the required stuff from aur, on the aur page it said it needs DesktopVideoHelper.service to be running, after starting it it worked flawlessly.

Occasionally after an update I had to set the service to autostart again, but that solved it again.

Today it didn’t work, I assumed it was the usual thing where I had to start the service again, however…

 raccoon@trash  ~  sudo systemctl status  DesktopVideoHelper.service
[sudo] password for raccoon: 
● DesktopVideoHelper.service - DesktopVideo helper daemon
     Loaded: loaded (/usr/lib/systemd/system/DesktopVideoHelper.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2022-05-30 11:07:54 CEST; 10min ago
   Main PID: 783 (DesktopVideoHel)
      Tasks: 3 (limit: 38440)
     Memory: 5.0M
        CPU: 2ms
     CGroup: /system.slice/DesktopVideoHelper.service
             └─783 /usr/lib/blackmagic/DesktopVideo/DesktopVideoHelper -n

mag 30 11:07:54 trash systemd[1]: Started DesktopVideo helper daemon.
mag 30 11:07:54 trash DesktopVideoHelper[783]: Start
mag 30 11:07:54 trash DesktopVideoHelper[783]: Listening for DesktopVideo settings changes

It’s already running. I tried rebooting and I doublechecked that it wasn’t the card’s fault, to make it quick I booted windows and checked there, it works, so at least I know that the card isn’t fucked and that everything is plugged in correctly, now I only need to figure out why it’s not showing up on linux.

I tried using it on OBS where it’s not listed but I also checked the blackmagic program where it says that no device is detected.

I confess I’m a little frustrated because it’s one of the things I use the most.

EDIT:

 ✘ raccoon@trash  ~  inxi -Fxxc0z --no-host | eos-sendlog  
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4989    0    24  100  4965     36   7608 --:--:-- --:--:-- --:--:--  7640
https://clbin.com/oBSW5
 raccoon@trash  ~  journalctl -b -0 | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  303k    0    24  100  303k     20   259k  0:00:01  0:00:01 --:--:--  259k
https://clbin.com/ZXxTi

1 Like

You might want to consider posting the terminal output as text.
It will make it searchable by search engines and possible to quote if needed.
Just copy-paste-highlight and press Ctrl-E.

Also:

Good luck with the troubleshooting!

:enos_flag:

1 Like

Thank you, hopefully I’ll get it to work. I edited my message to give more info and to post the output as text.

1 Like

Thank you so much!
Wish you the best of luck for getting this issue resolved!

Just an observation from your inxi:

Device-1: Blackmagic Design Intensity Pro 4K driver: N/A pcie:
speed: 2.5 GT/s lanes: 4 bus-ID: 23:00.0 chip-ID: bdbd:a139

Looks like it’s a driver issue.

Did the issue started after the kernel upgrade to 5.18? If positive, it’s possible that the driver wasn’t rebuild for the new kernel serie and need to be re-installed/ rebuild.

Try to rebuild your Blackmagic AUR package(s), reboot and see if it will work.

Is it this one:

https://aur.archlinux.org/packages/decklink

?

Hi, indeed, it was that one, I’ll try rebuilding it and reboot.

1 Like

I tried but sadly it didn’t work.
And from yesterday my pc has started having connestion issues and now I’m all paranoid that it’s all connected and my drive is about to leave this planet.

Try switching to the LTS kernel and see if you still experience these issues.

If you don’t have it installed:

sudo pacman -Syu linux-lts linux-lts-headers

Reboot and choose the LTS kernel option on the boot menu.

That solved the capture card issue but when I booted there internet was 100% non working, as if there wasn’t anything plugged in at all.

1 Like

When booted into LTS, what say:

inxi -anN

systemctl status NetworkManager

?

Also if everything worked under the latest 5.17 that you were using, you could perhaps reinstall / downgrade to that version and put off updating to 5.18 until its next updates.

Other users are having various issues also with 5.18 at the moment.

I’ll reboot into LTS and let you know.

As for the other suggestion, how do I do that?

sudo downgrade linux
sudo downgrade linux-headers

Choose the latest 5.17 that are shown in the terminal.

 raccoon@trash  ~  systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Mon 2022-05-30 13:53:56 CEST; 1min 27s ago
       Docs: man:NetworkManager(8)
   Main PID: 748 (NetworkManager)
      Tasks: 3 (limit: 38440)
     Memory: 12.5M
        CPU: 78ms
     CGroup: /system.slice/NetworkManager.service
             └─748 /usr/bin/NetworkManager --no-daemon

mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4435] manager: rfkill: Wi-Fi enabled by radio killswitch; enabled by state file
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4435] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4435] manager: Networking is enabled by state file
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4449] settings: Loaded settings plugin: keyfile (internal)
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4464] dhcp-init: Using DHCP client 'internal'
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4464] device (lo): carrier: link connected
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4466] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4503] ovsdb: disconnected from ovsdb
mag 30 13:53:56 trash NetworkManager[748]: <info>  [1653911636.4504] manager: startup complete
mag 30 13:54:03 trash NetworkManager[748]: <info>  [1653911643.7177] agent-manager: agent[18272864b1e0af44,:1.23/org.kde.plasma.networkmanagement/1000]: agent registered


 raccoon@trash  ~  inxi -anN
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: N/A modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: SteelSeries ApS Arctis 7 wireless adapter type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-3.4:5 chip-ID: 1038:1260
    class-ID: 0300

If I downgrade it will it try to upgrade again whenever I do a pacman -Syu ?

yes, but you can:

sudo pacman -Syu --ignore linux linux-headers

Pay attention to what gets updated.

You could try updating later to 5.18.1 and see if some of issues you are having is gone by then.

Alright, do you reckon there’s a way to get internet working on lts?

How do I know when it’s safe to stop ignoring linux and linux-headers?

Please refer to:

You don’t :wink:
You need to try it and/or check on the forum for issues reported by other users.

I meant more like how do I know there’s a new version, like 5.18.X that I can try.
And when it happens, how do I stop ignoring?

Run

checkupdates

It will tell what packages are to be updated.

By the way, double check the

command. I am not at my Arch box now.

There is a variant:

pacman -Syu --ignore=PackageName

Do some searching on this. At any rate, pay attention to what is getting updated. You could always say n and research things further.

Alright, I downgraded, now the capture card works, internet does not.
It’s odd, because it did before.

Did you check the Wiki article?

I am not sure now what is going on.

Perhaps open a new thread for the networking issue :wink: :person_shrugging:t5: