Captive Portal menu isn't appearing

I am using the latest endeavour os with kde and Linux zen kernel. Whenever I tried to connect to any captive portal wifi, it doesn’t show the “log in” prompt or notification.

You can normally just navigate to whatever website in your browser and will be redirected accordingly

But as it say usually it should show in the browser …

I tried these solutions already, but they didn’t work. Moreover, captive-browser-git has some bugs which it ain’t letting it be properly installed.

Generally, what can obstruct you from being able to catch a WiFi captive portal when connecting to a public WiFi net are customized DNS settings system-wide, such as an installed VPN, unbound, dnscrypt-proxy, and the like.

Also, certain webbrowser-settings or -plugins may do the same, when they customize DNS settings.

Last not least, even uninstalled things like that may not be really setting your dns-settings back to the original way it should be.

Also, installing a different (new) webbrowser and configuring it as the main web-browser can help in some cases.

Just a hint, in case you (did) use something like this.

1 Like

Yeah, I believe your words, but I’d been facing this issue for like 4 months, and it’s been forcing me to use Window every time I go to college as it’s the only way to connect to the wifi. And I have tried everything to solve it, including whatever is suggested in the arch wiki.

I guess I should try a reinstallation. I’m going to do it either way but thought if in case, I could fix it.

I kept editing my above post, while you already answered…

(Better to try and fix an issue, than to ‘blindly’ re-installl the whole system.)


1 Like

what is the DE you are using?
We do have such wifi in public transport i could try hacking it :wink:

lmao, I am using the latest KDE plasma.

i mean really i could try what happens i am regularly driving u-bahn so not a problem to try it …