Can't use my computer after it logs out and blanks due to inactivity

For a few days now, every time my computer is inactive and blanks out, I come back unable to do anything and forced to manually turn my computer off and on. It is unbearable, given when I take breaks I can’t even use my computer properly afterwards. I’d like some help, if possible.

I am using the i3WM.

using ann added screen locker or similar to the setup?

Not that I’ve configured. Just endeavour with i3.

# Lock the system

# lock with a picture:

#bindsym $mod+l exec i3lock -i ~/.config/i3/i3-lock-screen.png -p default win -t

# lock by blurring the screen:

bindsym $mod+l exec ~/.config/i3/scripts/blur-lock


# set powersavings for display:
exec --no-startup-id xset s 480 dpms 600 600 600

is all we set there and blur-lock do only lock theb screen not powering it off…

Not sure what if you system may go to sleep somehow?

If this happens can you switch TTY? Ctrl+Alt+F1 till F7 ?

is this intel GPI / Igpu?
inxi -Fxxc0z | eos-sendlog (hardware vinfo filtered)

journalctl --since "10 minutes ago" could show part where it happns… (not filtered)

Eh, what happens exactly is that the screen goes black, and I can only see my mouse. I don’t get any GUI interface other than that. What does TTY mean?

cli input aside from wm / Desktop…
your WM/Xsession is mostly on F7 where the others are showing a prompt to login without x…

Here’s the link!
What did you mean by the 2nd line?

I can try next time it happened, I didn’t try then. However nothing I did try worked.

i can think of two workarounds for now…
first try to set dpms to be disabled so diosplay will not get blacked out and powered off by software…
by change this in ~/.config

# set powersavings for display:
#exec --no-startup-id xset s 480 dpms 600 600 600
exec --no-startup-id xset s off -dpms

or go install a locker like light-locker to take over in case it blanks …

yay -S light-locker and comment the line in .config:

# set powersavings for display:
#exec --no-startup-id xset s 480 dpms 600 600 600

this xset s off -dpms is also püossible to use as a command from terminal as is,.
see here:

there is also a setting tool for light locker:

aur/light-locker-settings 1.5.4-1 (+5 1.08) 
    A simple GUI configuration utility for light-locker

yay -S light-locker-settings

Thank you! I’ll try them both.

you can also go first to comment the xset line in the config and try the disable command manually… And in case realy try if TTY is responding… so you may can switch to F4 and back to F7 to get your x-session back…