Can't use ElanTech Fingerprint reader on Lenovo E14 G3

Hello, I’ve been trying to solve this problem about 2 weeks and even tried the fixes on Framework Forums.
The issue is that my fingerprint reader is supported by fprintd according to their site (04f3:0c4b). When I try to enroll a fingerprint it says “the device is disconnected” then I close that window the window before it says “Failed to claim fingerprint device ElanTech Fingerprint Sensor: the device is already claimed by another process”

Here’s the terminal process:
[haorelian@ThinkPad ~]$ fprintd-enroll
Using device /net/reactivated/Fprint/Device/0
Enrolling right-index-finger finger.
Enroll result: enroll-stage-passed
Enroll result: enroll-stage-passed
Enroll result: enroll-disconnected

I’ve tried to remove and reinstall the fprintd and I can’t seem to make it work.

Some people told me that this issue may be caused by UEFI BIOS, so I’ve checked it and had no option under security to reset fingerprint reader.

Any ideas? Thank you all in advance.