Can't use completion on bash/zsh with yay, but I can use it with pacman

As title says, I can’t use tab completion neither with bash or zsh.
I tried what this post says with no luck.
I checked and the packages are installed:

>pacman -Qs | grep compl
local/bash-completion 2.11-3
    Programmable completion for the bash shell
    A complete, highly portable implementation of the DNS protocol
local/kcompletion 6.1.0-1 (kf6)
    Text completion helpers and widgets
    A complex camera support library for Linux, Android, and ChromeOS
    A complex camera support library for Linux, Android, and ChromeOS - signed IPA
    Library for the arithmetic of complex numbers with arbitrarily high precision
    A library that encapsulates the logic for complex text layout
    Automagic shell tab completion for Python CLI applications
    Provides WebSocket communication compliant with RFC 6455
local/zsh-completions-git 0.35.0.r84.g83cbd81-1
    Additional completion definitions for Zsh

What does pacman -Ql yay | grep compl return?

yay /usr/share/bash-completion/
yay /usr/share/bash-completion/completions/
yay /usr/share/bash-completion/completions/yay
yay /usr/share/fish/vendor_completions.d/
yay /usr/share/fish/vendor_completions.d/

How are you trying to use completions with yay? Can you give us an example?

for suggesting packages from aur:
for example yay -S vs
should list vscode etc…

EDIT: seems like re-running yay -Sc and simply logging out and login fixed it.
(obviously I did it last time I tried, I don’t know what changed)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.