Can't update, nothing to do

I haven’t updated my system in over a week and pacman is showing the red dot that there are updates.
I run sudo pacman -Syu and I get

Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Starting full system upgrade...
 there is nothing to do

Update your mirrors.

1 Like

Red dot? Where does that happen?

I had installed a pacman update warning a while back. It’s an exclamation point.

1 Like

I did using reflector. I’ll try updating again, thanks.

i would bet on mirrorlist also.

1 Like
error: aborting due to previous error

error: could not compile `pin-project-internal`

To learn more, run the command again with --verbose.
warning: build failed, waiting for other jobs to finish...
error: build failed
==> ERROR: A failure occurred in build().

Same there is nothing to do. Switch from Greece to WorldWide.

It looks like reflector simple ignored my command, and it’s back to Greece.
It keeps changing back to the location it wants. :hot_face:

Do you have reflector service updating your mirrors?

If you want to show error messages, please show also the command and parameters you used. That helps us help you.

You could try reflector directly, something like:

sudo reflector -c GR,DE -phttps -a2 -f10 --save /etc/pacman.d/mirrorlist

Use command

reflector --list-countries

to see the countries with supported mirrors.

EDIT: added the save stuff, thanks @xircon !

 sudo reflector --latest 20 --country GB,DE --age 12 --protocol http,https --sort rate --save /etc/pacman.d/mirrorlist

Don’t forget the save bit :smiley:


@manuel, http w/o s? We’ve 2021.

@Alexander, …

yay -Syyu

Packages are signed.

1 Like

I got this after.

alexander@alexander-x550ld ~]$ sudo pacman -Syu
[sudo] password for alexander: 
:: Synchronizing package databases...
 core                  131,2 KiB   516 KiB/s 00:00 [----------------------] 100%
 extra                1621,4 KiB  4,13 MiB/s 00:00 [----------------------] 100%
 community               5,5 MiB  5,14 MiB/s 00:01 [----------------------] 100%
 multilib is up to date
 endeavouros            16,6 KiB  0,00   B/s 00:00 [----------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (6) mpv-1:0.33.1-1  poppler-21.04.0-2  poppler-glib-21.04.0-2
             run-parts-4.11.2-1  xf86-input-libinput-1.0.0-1  yad-9.2-1

Total Download Size:    3,19 MiB
Total Installed Size:  13,76 MiB
Net Upgrade Size:       0,04 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 run-parts-4.11.2...    28,9 KiB  7,05 MiB/s 00:00 [----------------------] 100%
 poppler-21.04.0-...  1343,7 KiB  2,89 MiB/s 00:00 [----------------------] 100%
 poppler-glib-21....   259,1 KiB  5,75 MiB/s 00:00 [----------------------] 100%
 xf86-input-libin...    37,4 KiB  9,13 MiB/s 00:00 [----------------------] 100%
 mpv-1:0.33.1-1-x...  1399,2 KiB  4,55 MiB/s 00:00 [----------------------] 100%
 yad-9.2-1-x86_64      202,6 KiB  5,35 MiB/s 00:00 [----------------------] 100%
(6/6) checking keys in keyring                     [----------------------] 100%
(6/6) checking package integrity                   [----------------------] 100%
(6/6) loading package files                        [----------------------] 100%
(6/6) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
(1/6) upgrading mpv                                [----------------------] 100%
(2/6) upgrading poppler                            [----------------------] 100%
(3/6) upgrading poppler-glib                       [----------------------] 100%
(4/6) upgrading run-parts                          [----------------------] 100%
(5/6) upgrading xf86-input-libinput                [----------------------] 100%
(6/6) upgrading yad                                [----------------------] 100%
:: Running post-transaction hooks...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Compiling GSettings XML schema files...
(3/4) Updating icon theme caches...
(4/4) Updating the desktop file MIME type cache...
[alexander@alexander-x550ld ~]$

I wonder If Mulvad has anything to do with it. I’ll try it again without it.
…There is nothing to do.
My computer is lazy.

I don’t think yay makes a difference If you put -Syyu after it, although I could be wrong, I’ll try it.

So the system got updated after refreshing the mirrors?

No, it did not.
It almost worked with yay -Syyu but failed on making mulvad. It seems there is a problem there with it.

But your output from sudo pacman -Syu indicates that it did. Or am I missing something?

It says it did, but it never went over the dots, it displayed it in a couple of seconds
yay -Syyu did quite a bit. I’m going to re try it without Mulvad