Can't type root password while booting EndeavourOs

I can’t log in to EndeavourOS because I can’t enter the root password required for maintenance. I’m not completely new to Linux, but I don’t have a lot of experience, especially with troubleshooting. :sweat_smile:

How I got to this problem:
I have an SSD with EnOS that I use for university and video post-production with DaVinci Resolve (no dual boot). I was able to get DVR to work without many problems. Everything worked fine, but suddenly DaVinci Resolve wouldn’t open (I clicked on the icon, and after a few seconds of the KDE app launch animation, nothing else happened. The process was still running). I’m quite knowledgeable about DaVinci Resolve, and I know that if it can’t launch, 99% of the time, it’s due to a GPU driver issue.

Over the last two days, I updated:

  • Arch Mirrorlist
  • EndeavourOS Mirrorlist
  • EndeavourOS (with yay)

I never updated any GPU driver. I was still using the amdgpu-pro driver. As in the past few weeks, I had some minor performance issues with EnOS (small input/video lags), I updated the BIOS to the latest version. After the BIOS update, I tried again to open DVR, but nothing changed. So I also tried to update DVR to the latest version (18.1.4). Still the same problem.

Then I remembered a backup I made with TimeShift on Sunday, March 20th, 2023, so I decided to use it to recover everything (until Sunday all worked perfectly). The backup contained only the EnOS SSD data (root and Hadron27 - my username - folders excluded).

The problem:
After the backup recovery, I tried to boot EnOS, but I’m stuck with a root password request that I can’t enter. To be more detailed:

  1. I turn on the computer, and the motherboard logo appears.
  2. A small GUI appears to choose between EnOS, EnOS fallback (or something similar), and the interface option.
  3. I select EnOS, and it starts booting up. It says “Welcome to EndeavourOS!” and a giant list of “OK.” Then I get a “FAILED” for all the internal and external NTFS disks of my system. Inside EnOS, I have set all those disks to mount during booting. The error message is always the same:
[FAILED] Failed to mount /home/hadron27/mnt/ntfs/Disk .
See "systemctl status "home-hadron27-mnt-ntfs-Disk\\x2Disk.mount"" for details.

After all the error messages, I get this line:

You are in emergency mode.After logging in, type "journalctl -xb" to view
system logs, "sistemctl reboot" to reboot, "systemctl default" or "exit"
to boot into default mode.
Give root password for maintance
(or press Control-D to continue): _

That’s my problem: I can’t enter my password or press Control-D. I can do nothing but hard reboot my computer.
Do you have any advice?

Thank you in advance,

P.S.: I’m sorry for the long post, but I tried my best to be as precise and clear as possible.
P.P.S: I’m so sorry for my bad English, it’s not my first language.

That box may not echo anything to the screen when typing. Have you tried entering your password and pressing enter?

If that doesn’t work, it is possible your boot image is missing something needed for your keyboard. Have you tried using a wired keyboard?

If you can’t get access that way, you can always boot off a live ISO and arch-chroot in. There are instruction in the EOS wiki for that.

1 Like

Hi @dalto! Thank you for your kind reply!!

I tried pressing enter multiple times but nothing happends…
I have got a wired keyboard with backlight. The keyboard seems to be initialized (I don’t know if this is the right word) as the leds are on and if I enable / disable Caps-Lock / Num Lock, the linked led on the keyboard works.
I have also tried to use a different wired keyboard and to unplug and plug back in the keyboard before typing the password. Sadly nothing works.

I have never tried to arch-chroot in with a live ISO so I’d prefer a simpler solution (if exists). Anyway thank you for the reference to the wiki!

I am not a Def, but curious. And musing.

Is it true that the computer did boot at first, but because DaVinci was not working properly, you went to another snapshot. And then it went wrong.

Could it be because the automount (fstab) of the disks from the snapshot, does not match the automount (fstab) of the current version of the system.


Hi @made-lief and thank you very much for your kind reply!

Yeah, that’s true!

Unfortunately the disks mount path match.
I have never used fstab, I simply checked the automount option with Gnome Disks (ex GParted), but I think that it does the same thing.
The strange thing is that it does perfectly automount the ext4 and btrfs disks, but it can’t mount ntfs disks (which usually mount without problems, even without write access - that I had granted).

Again, thank you very much for your answer!

What do you mean? Show some terminal output that proves that.

grep -v "^#" /etc/fstab | grep .
lsblk -f

Since you can’t boot, get the info with other means.

So, disable them, to boot succesfully, and after repairing your system you can add them back :person_shrugging: .

If you don’t want to troubleshoot this, you can always re-install the system. :person_shrugging:

Note: My Magic Crystal Ball :crystal_ball: is at the repair shop for refactoring, so I can’t see inside your system.


1 Like

Hi @petsam ! Thank you for your kind reply!

I tried to arch-chroot in with the live ISO, as suggested by @dalto , and I was able to solve the keyboard issue but I found out some major problems.
I used Timeshift for the first time this afternoon. It successfully recovered all the folders and the files apart from root and home folders (as set up before creating the backup - default choice). I thought that it would recover all the files and ignore root and home folders, instead it deleted all their content (maybe it isn’t Timeshift fault, I may have done something wrong).

So I guess that the only way to use EnOs again is to perform a clean install, am I right?
I think that I may be able to get the current EnOs disk to work, but I would still miss all my settings, personalizations and apps, am I right?

Thank you all for your support!

I also thought so. Is the /home folder on a separate partition? (in /etc/fstab)

If the only missing are what you said, maybe not required to re-install.
Unless your system is not running well, or has errors (messages, or behavior)… :person_shrugging:

1 Like

The /home folder was on the same partition. I don’t know wether I did something wrong with Timeshift…

When trying to boot I get some error messages of missing core files (or something similar, I can’t remember the exact error code).
As I have urgency to work with DaVinci Resolve I will perform a clean install on a different SSD. Then, maybe, I’ll try to fix the existing one.

Again thank you very much to you all for the kind replies. Asking for help on this forum was a great experience!

I’ll update this topic if I can recover EnOs with the steps that I did, so that maybe it can help someone else.

1 Like