Can't switch kernels in Grub

I wonder if I am the only one who is not able to switch kernels in grub?
I have four lines but can’t pick another line than the upper one.

It seems that my keyboard is not working, I can’t use the arrow keys nor the page-up or down keys.
This used to work well in the past but stopped a few weeks ago.

I have to alter the grub.cfg if I would like to boot with another kernel.

What is in your /etc/mkinitcpio.conf about HOOKS?
I have

HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck"

I have…

HOOKS=“base udev autodetect modconf block keyboard keymap resume filesystems fsck”

Quite the same, I only have an extra resume.

I guess resume is related to using swap, and I don’t have swap. So no problem there.

Have you tried a different keyboard? Especially a wired one (if you now have wireless)?

It’s a laptop.

  Host: richard-pc Kernel: 5.4.19-1-lts x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: EndeavourOS 
  Type: Portable System: Dell product: Inspiron 15-3552 v: 4.4.0 
  serial: <filter> Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: ������ v: ��� serial: <filter> UEFI [Legacy]: Dell 
  v: 4.4.0 date: 03/06/2018 
  ID-1: BAT0 charge: 30.1 Wh condition: 30.1/37.3 Wh (81%) volts: 16.5/14.8 
  model: PANASONIC DELL 78V9D63 type: Unknown serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 5% (should be ignored) rechargeable: yes status: Discharging 
  Topology: Dual Core model: Intel Celeron N3050 bits: 64 type: MCP 
  arch: Airmont rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6400 
  Speed: 1873 MHz min/max: 480/2160 MHz Core speeds (MHz): 1: 1873 2: 1349 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1 
  Display: x11 server: X.Org 1.20.7 driver: intel 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:2284 
  Sound Server: ALSA v: k5.4.19-1-lts 
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: f040 bus ID: 01:00.0 
  chip ID: 168c:0036 
  IF: wlan0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-2.1:12 
  chip ID: 0cf3:e005 
  Local Storage: total: 119.24 GiB used: 41.35 GiB (34.7%) 
  ID-1: /dev/sda vendor: Crucial model: CT128MX100SSD1 size: 119.24 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: MU03 scheme: MBR 
  ID-1: / size: 108.73 GiB used: 41.32 GiB (38.0%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.27 GiB used: 32.2 MiB (0.4%) fs: swap dev: /dev/sda2 
  System Temperatures: cpu: 26.0 C mobo: 33.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 182 Uptime: 5h 13m Memory: 3.76 GiB used: 1.80 GiB (48.0%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.37 

Well, I see that kernel 4.19 is gone and has been replaced with 5.4. :face_with_raised_eyebrow:

Do the navigation keys work reliably after you have booted past grub?
What do the following lines look like in your /etc/default/grub?

# Uncomment to use basic console

# Uncomment to disable graphical terminal

Can you check your keyboard layout in bios?

Nav keys work normal after boot.

Grub lines are looking the same.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

Keyboard layout is not available in my Bios.

What happens when you try to navigate with <ctrl>+c and <ctrl>+g ?

It seems to have a problem on this model Dell Inspiron 15-3552 for keyboard unfortunately !

I saw you have the latest Bios 4.4.0. Maybe try the capslock key that sometimes lock the keyboard, they did a new driver this december but only for Win !

Follow what @manuel told with a wired usb keyboard to test…

Does this problem happen when you boot or reboot the machine, or when you come back from hibernate?

I never use hybernate but suspend only.
Then there is no grub involved.

So, only when I boot the laptop this problem occurs.

See if you can re-arrange boot order using grub-customizer package.

Be very careful before you save the grub order menu! Also, try to see if you can use the 'up/down" keys using an external wired keyboard.

Ctrl c or g doesn’t do anything, nor does Capslock.
I am able to pick another kernel by altering the value of first line from the grub file.
But this not very comfortable.
Well, don’t need need to pick another kernel anyway…

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_idle.max_cstate=1 resume=UUID=31fc204a-f877-4128-b63f-ac70b0d5312e loglevel=3"

Do you remember what you did at the time (a few weeks ago) when keyboard stopped working?
Maybe an update? A kernel update?

There’s an app called pahis (package history) that you can install with pacman. It shows you history of e.g. package updates or installs.

1 Like

No, I don’t know which update caused it, if an update did this.
Don’t even know how long this issue teases me.