Can't stop autologin

I made the mistake of setting the setting myself to autologin (no login screen or password request) when I installed EOS today and I cannot for the life of me find how to stop it doing that. None of the posts I’ve seen on my search has solved it, so I’m stuck for the moment.

I’m running kde plasma 6 (defaults to Wayland). I suspect the answer is somewhere in these two files but I don’t know what to change/delete.

Any help appreciated.

This is my kde_settings.conf:


HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot



This is my sddm-autologin:

auth required
auth required preauth
auth required
auth required
auth required
-auth optional
-auth optional
account include system-local-login
password include system-local-login
session include system-local-login
-session optional auto_start
-session optional auto_start

I did the exact same thing with the same regret. I did two things in quick order, so it might be either one that fixed it for me.

  1. Deleted the autologin section from kde_settings.conf (pretty sure this was the first and I think I rebooted afterwards, noting that I was stille being logged in automatically)
  2. System settings | Colors & Themes (under Appearance & Style heading) | Login screen (SDDM) → then find the “Behavior” settings just above the displayed themes. Untick “Automatically log in”

I would start with the last one, apply and reboot and take it from there, if I were you.

Hi brokkr.

Thanks for the help. It’s fixed now, but I’m not sure how.

2 - Automatically log in wasn’t checked. I was really hoping it was that simple.
1 - Rebooted after but it made no difference at all.

So I went back into the Login Screen (SDDM) and clicked on Defaults, rebooted and that fixed it. Absolutely no idea why.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.