Can't set desktop background

Hi, yesterday I updated EOS and my background image disappeared. I tried to set up a new but it seems to stop working.

Does the following help:

  • right click on the desktop
  • select Desktop settings (my translation, may have other wording)
  • near the lower right corner click the Style menu and select e.g. Stretched (I assume you had Nothing)


right click on the desktop - stopped working also… :expressionless:

nothing happens when selecting stretched and others options

I am not an Xfce user so I couldn’t give any “qualified” advice.

However if you think that something getting updated might have broken this functionality, I would look into the pacman log for the date when your system got updated to see if there is anything relevant in there.

hmmm no think update . full update near basic stock Xfce on EOS . run perfect

possible usr mod something that affect ?



You could launch the settings manager with the debug option, it’s very verbose, but you might find some relevant infos.

xfdesktop-settings -e

thank you

logs are ok

DBG[main.c:908] cb_image_selection_changed(): got /home/slawtul/Pictures/wallpaper/583368.jpg, applying to screen 0 monitor eDP workspace 0
DBG[main.c:819] xfdesktop_settings_generate_per_workspace_binding_string(): name /backdrop/screen0/monitoreDP/workspace0/last-image
DBG[main.c:916] cb_image_selection_changed(): Saving to /backdrop/screen0/monitoreDP/workspace0/last-image//home/slawtul/Pictures/wallpaper/583368.jpg

What if you quit the desktop and reload it:

xfdesktop --quit && xfdesktop --reload



I am able to see/change background

but I cannot close this window or stop this command xfdesktop --quite … (with ctrl+c):

if I click close button - window is freezing…

Try: Ctrl-Z

Yes, command is stopped but if I want to close this window I cannot - it’s freezed.

Type: exit

Nothing, freezing, I cannot click window buttons (close, minimize, maximize)

Let me show you:

Peek 2023-04-14 11-48

Something is missing in the session, in system settings. Investigate what is going on there. Might have to add a “bash” script with the commands pebcak suggested.

Before that, restart the system. If it doesn’t fix things, might have to create the script and add it to session start. Not sure about this because I’m on EndeavourOS but with MATE not XFCE.

The Ctrl-Z has seemingly paused/stopped the job but it is somehow still stuck in the background.

What does:



❯ xfdesktop --quit && xfdesktop --reload
[1]+  Stopped                 xfdesktop --reload

~ on ☁️ took 18s 
✦ ❯ jobs
[1]+  Stopped                 xfdesktop --reload

Close all the other programs running.

Then do this: kill -9 $(jobs -ps)

Check with fg or jobs to see if it is gone.

Hope this works.


I ran this command in Kitty, I was able to Ctrl+z and close the kitty window. I can open any other application eg: chrome, firefox, thunar but I am not able to close this windows.

Ok guys thank you for your help but it worthless to spend more time on this. It’s just a background.

thanks pebcak
this last command you sent - helped.

What i did:

  1. open terminal
  2. run: xfdesktop --quit && xfdesktop --reload
  3. ctrl-z
  4. kill -9 $(jobs -ps)

and I am able to open other apps, terminals and close them clicking in ‘close’ button

so how to automate it?