Can't run bioshock 2 remastered from egs

I have bioshock 2 remastered on epic games which I run through lutris, when I first tried to run it egs opened the 2k launcher (pesky launchers), when I press play in the 2k launcher it does nothing so I tried to tinker and make egs run the game directly without the launcher which did not work and the game prompts to repair instead of run in egs, when i press repair it verifies then asks to repair again, I tried to undo the text file changes I did but it still asks for repair, I then tried to run the exe file with wine but it only shows a small splash screen of bioshock 2 for a few seconds then disappears, I can’t just reinstall the whole game as I live in a hole where wifi is limited and costly otherwise I would’ve just installed another game, thanks in advance.

egs is epic games store btw

Have you tried using Heroic Games Launcher?

or if you want to install via AUR

yay -S heroic-games-launcher-bin

Imported the game to heroic and it restored the 2k launcher, which now prompts me to “install egs” instead of “play” which when pressed brings up a wine error saying “theres is no windows program configured to open this type of file”, 2k launcher then updates the status of the game to “game playing” and nothing happens

Always Check on
If they have any tips or tricks to get the game to start/run.
And yes you can run with Proton outside of steam.
there are guides out there for it.

1 Like

this appears to have fixed it for me, i tried doing it before but my mistake was that i copied the path to the exe from my machine instead of copying from the c drive

Great! Yeah Protondb usually have solutions for problems.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.