Can't mount one of my internal SSD's NTFS partition

I am dual-booting EOS with Windows. I have two SSDs, each with an NTFS partition. I am able to mount the NTFS partition that is on a different SSD, but not able to mount the NTFS partition that is on the same SSD as the ext4 partiton of my EndeavourOS.

I got the following message when mounting it from KDE’s Dolphin file manager:

An error occurred while accessing 'Data', the system responded: The requested operation has failed: Error mounting /dev/nvme0n1p1 at /run/media/beforesunset/Data: wrong fs type, bad option, bad superblock on /dev/nvme0n1p1, missing codepage or helper program, or other error

[beforesunset@victus-eos ~]$ lsblk -l
nvme0n1   259:0    0 232.9G  0 disk
nvme0n1p1 259:1    0   147G  0 part
nvme0n1p2 259:2    0   512M  0 part /efi
nvme0n1p3 259:3    0   7.8G  0 part [SWAP]
nvme0n1p4 259:4    0  77.5G  0 part /
nvme1n1   259:5    0 476.9G  0 disk
nvme1n1p1 259:6    0   100M  0 part
nvme1n1p2 259:7    0    16M  0 part
nvme1n1p3 259:8    0 476.1G  0 part /run/media/beforesunset/Windows
nvme1n1p4 259:9    0   775M  0 part

I also tried Check and Repair partition option from KDE Partition Manager but that didn’t solve anything. I assume it does fsck on the partition.

System information:

Operating System: EndeavourOS 
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.3
Kernel Version: 6.8.2-arch2-1 (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 5600H with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: HP
Product Name: Victus by HP Laptop 16-e0xxx
1 Like

Is this a laptop with an extra internal drive you are using for files?

Edit: Sorry i got confused reading it over quickly. :laughing:

It’s a laptop with 2 SSDs. One has Windows’ C partition, the other SSD has another partition with my files

You probably have to add it to the fstab? :thinking: I’ll let someone with more knowledge advise you as i don’t want to give you inaccurate information.

ntfsfix which is part of ntfs-3g fixed for me.:

sudo ntfsfix -b -d /dev/nvme0n1p1

More information from the --help flag

-b, --clear-bad-sectors Clear the bad sector list
-d, --clear-dirty Clear the volume dirty flag

1 Like

Yes… i forgot about that one being used frequently. :wink:

If you are sharing those NTFS partitions with Windows, make sure that you have Fast Startup and hibernation disabled in Windows.

I have the same problem with an external drive I use for the headunit in my truck which is formatted ntfs. ntfsfix worked once in eos, but now it doesnt. I get error saying something about a bad superblock, or wrong file system. Interesting thing is I can plug it into my laptop which has pop os, and it has no problems with it.

I had turned off Fast Startup off before installation.

Maybe try chkdsk from Windows side once.

Thanks but I d rather catch a cold than use Windows again :face_vomiting:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.