Can't mount any drive as read-write, external or internal

When I first installed EndeavourOS with KDE, I could mount my drives using Dolphin.

A few days ago, I set up fstab using KDE Partition Manager. Everything looked like it’s fine, until I rebooted. The system weren’t able to, and still not able to, find the drives I added to fstab. It didn’t booted. I fixed it by using nofail, nobootwait I was now able to boot. But…

  1. None of my drives are mounted as read-write, they are always mounted as read-only

  2. External drives can’t be found on boot, internal ones gets mounted(but as I said, read-only).

  3. Also Dolphin can’t mount, gives this error:
    An error occurred while accessing '[label name]', the system responded: The requested operation has failed: Error mounting system-managed device /dev/[partition node]: wrong fs type, bad option, bad superblock on /dev/[partition node], missing codepage or helper program, or other error
    KDE Partition Manager can mount but only as read-only.

However, all drives works fine in my Windows 10 installation.

Tried to use fixing commands, for example Windows’ ones or fsck.exfat. Gave no errors. Removed them from my fstab, Dolphin still wasn’t able to mount them. I tried to mount them to different folders, it didn’t worked too.

Here’s my fstab:

UUID=E272-B3C7 /boot/efi vfat noatime 0 2
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71 / btrfs subvol=/@,noatime,compress=zstd 0 0
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71 /home btrfs subvol=/@home,noatime,compress=zstd 0 0
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71 /var/cache btrfs subvol=/@cache,noatime,compress=zstd 0 0
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71 /var/log btrfs subvol=/@log,noatime,compress=zstd 0 0
/dev/sda2 /mnt/internalA ntfs nofail,nobootwait 0 0
/dev/sdc /mnt/internalB ntfs nofail,nobootwait 0 0
/dev/sdb4 /mnt/windows ntfs nofail,nobootwait 0 0
UUID=F009-D277 /mnt/externalA exfat nofail,nobootwait 0 0
UUID=0CA6-383E /mnt/externalB exfat nofail,nobootwait 0 0
UUID=5899-CCA7 /mnt/externalgaming exfat nofail,nobootwait 0 0

(I’m using UUIDs because I want to my files on external disks to to mount on same folders, regardless of when I plugged them. But it doesn’t changes anything even if I use partition nodes.)

your missing defaults in your fstab.

UUID=12345678987654321 /home/thefrog/Data ext4 defaults,noatime 0 2

That isn’t the full fstab. Posting full fstab isn’t compatible with BBCode. Here’s the full one:

Am I still missing the defaults? If so, how can I add them? Also, should I do them for NTFS partitions too?

Please post terminal output as text for better readability.

Copy, paste, highlight and press Ctrl-E to format.

1 Like

nofail do not report errors for this device if it does not exist.

you should remove the nofail to see what errors you get when trying to boot.

post the output just don’t tell us? If we cant see whats going on how do you expect us to help?

I think you should explain what I should do. As you can see, this post is tagged as “Newbie”.

its this simple what do you not understand about it?

I thought this place was newbie friendly. Not all of our comunnity are newbie friendly then.

since you posted a picture i assumed you knew how to get us the information needed.

Step by Step
open the fstab file and copy the entire contents of the file.
navigate to this page and then paste (right mouse click or key combo Ctrl + v)
highlight the newley pasted text and then press Ctrl + E to format the output for easier reading.
navigate back to the fstab file and close it if not already and as soon as someone can get to it they will look at your post and give information based on the errors we can see.

1 Like
New                                         Partition             /mnt/internalB   nofail,nobootwait                      0 0 #New Partition                               /mnt/internalB   /mnt/internalB   nofail,nobootwait                      0 0 # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=E272-B3C7                              /boot/efi             vfat             noatime                                0 2 
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71   /                     btrfs            subvol=/@,noatime,compress=zstd        0 0 
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71   /home                 btrfs            subvol=/@home,noatime,compress=zstd    0 0 
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71   /var/cache            btrfs            subvol=/@cache,noatime,compress=zstd   0 0 
UUID=5b257c34-fd04-42b2-9ce0-dc3b0db8dc71   /var/log              btrfs            subvol=/@log,noatime,compress=zstd     0 0 
/dev/sda2                                   /mnt/internalA        ntfs             nofail,nobootwait                      0 0 
/dev/sdc                                    /mnt/internalB        ntfs             nofail,nobootwait                      0 0 
/dev/sdb4                                   /mnt/windows          ntfs             nofail,nobootwait                      0 0 
UUID=F009-D277                              /mnt/externalA        exfat            nofail,nobootwait                      0 0 
UUID=0CA6-383E                              /mnt/externalB        exfat            nofail,nobootwait                      0 0 
UUID=5899-CCA7                              /mnt/externalgaming   exfat            nofail,nobootwait                      0 0

:slightly_smiling_face:

Learned it today. Not many forums have support for something like this.

Please see this thread

a quick read here tells you how to post things to the forum.

we also need to see the output of
lsblk -f

1 Like
$ lsblk -f

NAME FSTYPE FSVER LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                       
├─sda1
│                                                                                         
└─sda2
     ntfs         bütün dosyalar      1A62F18162F16245                      564,9G    70% /mnt/internalA
sdb                                                                                       
├─sdb1
│    ntfs         Kurtarma            3876A46676A4269A                                    
├─sdb2
│    vfat   FAT32                     4CA5-7FC0                                           
├─sdb3
│                                                                                         
└─sdb4
     ntfs         windows and steam   6C04B2A604B27326                       84,3G    81% /mnt/windows
sdc  ntfs         the sims and others 779B80CF302CDC98                      142,9G    52% /mnt/internalB
sdd                                                                                       
├─sdd1
│    vfat   FAT32                     E272-B3C7                             997,4M     0% /boot/efi
└─sdd2
     btrfs        endeavouros         5b257c34-fd04-42b2-9ce0-dc3b0db8dc71  885,8G     5% /var/cache
                                                                                          /var/log
                                                                                          /home
                                                                                          /
sde                                                                                       
└─sde1
     exfat  1.0   OTTOSCOLLE3         0CA6-383E                                           
sdf                                                                                       
└─sdf1
     exfat  1.0   OTTOSGAMING         5899-CCA7                                           
sdg                                                                                       
└─sdg1
     exfat  1.0   OTTOSCOLLEC         F009-D277

(Yes some of the partition haves their labes in Turkish. :slight_smile:)

First off you are putting the external drives under /mnt which is owned by root. so ofcourse you don’t have permission to access those. you need to change /mnt to something like /home/otto/$DEVICE or some other name you entry should look like this

where you have

UUID=5899-CCA7                              /mnt/externalgaming   exfat            nofail,nobootwait                      0 0

this would be better

UUID=5899-CCA7                              /home/otto/externalgaming   exfat            nofail,nobootwait                      0 0

Did it. It didn’t worked. They are still read-only. The folder I created works fine however.

Since I don’t use any Microsoft formats on my drives I’m not sure why its read only unless it has something to do with the nofail automatically making a drive read only again Since I have never used this option I’m not sure if that is what it does or not.

however you still need to add defaults to the options

from man7.org

defaults use default options. The default depends on the kernel and the filesystem. mount(8) does not have any hardcoded set of default options. The kernel default is usually rw, suid, dev, exec, auto, nouser, and async.

Both NTFS and exfat doesn’t works. And nofail is necceseary for me because if I don’t add that my system becomes unbootable if it doesn’t finds a certain drive.

Did it. Still mounts read-only.

Well good luck